mouse cursor disappears when hovering

Hi All;
OS 12.1 with KDE 4.7.2 - when hovering the cursor in an application or over an icon it disappears. It reappears when I move it or press one of the buttons but disappears again when it stops moving. I’ve searched the bug reports and this forum but haven’t seen any other instance of this problem. Except for this the desktop has been very stable for me.

I tried changing cursor scheme ( I prefer redglass) but they all show the same activity. When I switch to OS 11.4 (multi-boot) the cursor remains visible at all times. Is the mouse cursor handled differently in 12.1?

Video: ASUS EN210 (GeForce 210)
chipset: NVIDIA nForce 980a SLI

Thanks, Tom

> OS 12.1 with KDE 4.7.2 - when hovering the cursor in an application or
> over an icon it disappears.

try turning off desktop effects…does that change the behavior?
if so, try turning the effects back on, but individually disable some of
the effects…until you find the one causing the problem…

or, maybe if you change the window theme…

otherwise you probably have to experiment with a different video driver,

oh! does this only happen when you have a browser page active with Flash
running??? (open top and see if you have a “plugin-containe” (if running
firefox) or “operapluginwrap” (if running Opera) or, if running chrome a
new instance of ‘chrome’ (there are probably several ) using a very
high level of CPU…if you kill the browser with Flash running, does
the mouse become always visible??

openSUSE®, the “German Engineered Automobiles” of operating systems!

I’ve now tried disabling desktops effects but that did not solve the problem. The only desktop effect I had used was mouse mark but disabling it didn’t work either. The problem is only exhibited in 12.1, not in 11.4 where it never disappears.

Thanks anyway, Tom

Video card? driver?

Hardware and driver are same ones used under OS 11.4 which did not exhibit this problem.

After a bit more experimenting, found that it mostly happens when a menu or some part of a game is clicked, then the cursor disappears if the mouse is not moved (i.e. in kpatience, while playing klondike, when I click on the draw pile, the cursor disappears after the click until the mouse is physically moved.


On 12/27/2011 09:06 AM, tommyttt wrote:
> Hardware and driver are same ones used under OS 11.4 which did not
> exhibit this problem.

ah, but the kernel is totally different, and the desktop moved from 4.6
to 4.7 and the . . .

suggest you log the bug:

openSUSE®, the “German Engineered Automobiles” of operating systems!

I confirm the very same behavior after having switched to KR47 repo with KDE4.7.4.
Overall the system is much more responsive then before, (still slower then with 11.4) but has now developed this intermittent cursor problem. Nvidia proprietary driver, default kernel, KR47. The mouse cursor theme is custom installed, therefore with all these variable I was not very motivated because it is not self evident to raise a bug without dismantling half of my system. But the OP makes me think it might be related to the original asset too. The cursor does not vanish, it “flickers” during movement. When not moving it reappears. Desktop effects are off, with “on” it is the same issue. The machine is updated from 11.4, no fresh install. Worked well up to two days ago. Do regularly update. So I guess the “culprit” is identifiable, provided the O.P. had the problem appear around two or three days ago as well.

I think I was using “White Glass” when I had this problem. It went away when I switched to an Oxygen White theme. If you are using Red Glass, there might be something in that theme that KDE doesn’t like.

I get this problem in 12.1 as well. It was on KDE default, and switching to Oxygen White did not solve it.

Which version of KDE4 are you using? KDE default = 4.7.2 only default repos (oss, noss, packman)?

Exactly. If I remember correctly, I tried several cursor themes and settled on Oxygen White. If nothing else is working, run through a few themes until you get one that works to your satisfaction. It takes only a few minutes.

The cursor disappears with all of the builtin cursor themes, even the oxygen white on my system. Will file bug report with KDE first, then SuSE.


Bug report had already been made as #283490. Others please add your comments to give more information to developers.


This problem went away when I installed the proprietary driver from ati. I think the issue occurs when you’re using a slow driver.