mouse configuration and xorg.conf?

Hi,

I hope this isn’t a stupid question, I spent a while to search for the answer but couldn’t find. I’d like to get at least the side buttons of my Logitech MX 518 working (KDE 4.3.1, oS 11.2). There are some threads explaining how to do eg http://forums.opensuse.org/archives/sf-archives/archives-hardware/345176-logitec-5-button-mouse-question.html but I can’t find xorg.conf, just xorg.conf.install. In my home folder there’s a xorg.conf.backup, but I wonder if it’s a remaining of 11.1. Well, and I’m not sure if it’s a good idea to use the backup version and edit it. So, at the moment I’m pretty confused and don’t want to break something by doing silly things…
What could I try? Help is appreciated!

Edit: I just can use left and right button and the middle one, but not even the scroll wheel works (which I also would like to work).

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On openSuSE 11.2 the xorg.conf file is obsolete, it don’t exist by
default, but if you create one it is used, try using sax2 from a
terminal and let sax create a config file for you, then you can edit it


VampirD
No in elenath hîlar nan hâd gîn
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org/

iEYEARECAAYFAkteHPMACgkQJQ+0ABWtaVmv3QCfXdnFB9dRqr/WgeI3KtqS8ojv
9QwAniwevUIdXtoBl+mzn/8hZINrc9Ac
=5MES
-----END PGP SIGNATURE-----

However driver related mouse and keyboard settings will still be ignored unless you add:

Option “AllowEmptyInput” "off"

in the ServerFlags section. This is sometimes needed if the HAL daemon fails to dectect your mouse or keyboard. It might provide a solution in some (rare) cases but it might cause other problems too (specially regarding keyboard layout and key codes).

Take a look in /var/log/Xorg.0.log to see how your mouse is being detected. Type in a terminal:

grep -i mouse /var/log/Xorg.0.log

Thank you for your replies :)! I’ll run sax2 and add the mentioned option later this evening. I just wanted to post the output of grep -i mouse /var/log/Xorg.0.log

(==) NVIDIA(0): Silken mouse enabled
(II) config/hal: Adding input device PS/2 Generic Mouse
(**) PS/2 Generic Mouse: always reports core events
(**) PS/2 Generic Mouse: Device: "/dev/input/event0"
(II) PS/2 Generic Mouse: Found 3 mouse buttons
(II) PS/2 Generic Mouse: Found x and y relative axes
(II) PS/2 Generic Mouse: Configuring as mouse
(**) PS/2 Generic Mouse: YAxisMapping: buttons 4 and 5
(**) PS/2 Generic Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "PS/2 Generic Mouse" (type: MOUSE)
(**) PS/2 Generic Mouse: (accel) keeping acceleration scheme 1
(**) PS/2 Generic Mouse: (accel) filter chain progression: 2.00
(**) PS/2 Generic Mouse: (accel) filter stage 0: 20.00 ms
(**) PS/2 Generic Mouse: (accel) set acceleration profile 0
(II) PS/2 Generic Mouse: initialized for relative axes.
(II) Logitech Logitech USB Keyboard: Found 14 mouse buttons

To detect mouse and keyboard means to detect they are connected or to detect them correctly with all functions? And if it doesn’t work I simply can delete xorg.conf and things will work like now, won’t they?

Okay, so i run sax2 and things seem to work like before. Scrolling wheel has no effect and also the side buttons react like the middle button, but not forward/backward. I tried to edit the xorg.conf with several versions I found (just the mouse part of course), but non worked so far. Once the keyboard was affected (couldn’t log in because the letters were written twice…), the other times it ended up in CLI (after in enabled auto log-in, just in case… :wink: ).
**grep -i mouse /var/log/Xorg.0.log ** changed a bit

(**) |-->Input Device "Mouse[1]"
(**) Option "AllowMouseOpenFail" "on"
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules//input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
(==) NVIDIA(0): Silken mouse enabled
(**) Mouse[1]: Device: "/dev/input/mice"
(**) Mouse[1]: Protocol: "explorerps/2"
(**) Mouse[1]: always reports core events
(==) Mouse[1]: Emulate3Buttons, Emulate3Timeout: 50
(**) Mouse[1]: ZAxisMapping: buttons 4 and 5
(**) Mouse[1]: Buttons: 9
(**) Mouse[1]: Sensitivity: 1
(II) XINPUT: Adding extended input device "Mouse[1]" (type: MOUSE)
(**) Mouse[1]: (accel) keeping acceleration scheme 1
(**) Mouse[1]: (accel) filter chain progression: 2.00
(**) Mouse[1]: (accel) filter stage 0: 20.00 ms
(**) Mouse[1]: (accel) set acceleration profile 0
(II) Mouse[1]: ps2EnableDataReporting: succeeded
(II) config/hal: Adding input device PS/2 Generic Mouse

/etc/X11/xorg.conf reads (for the mouse part):

  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "PS/2 Generic Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"

Which settings should I try? And thanks for your help :).

It means to identify the model correctly. In your case, “PS/2 Generic Mouse” is totally wrong. I bet it’s not even a PS/2 mouse. Well, I don’t know. But if your mouse were detected correctly, its name would appear in the log. So you would see “Logitech MX 518” or something similar. “PS/2 Generic Mouse” indicates that a mouse has been found that could not be identified. In that case, the device might work with limited functionality.

It’s an USB-mouse connected via a PS/2 adapter. What could I do to help it identify the mouse? Maybe I could connect then without the adapter, could that make a difference?

Warnings are missing in your logs. I don’t know why. (or maybe I don’t know why mine are more verbose :slight_smile:
In the first case, I assume you didn’t turn off AllowEmptyInput and HAL failed to detect your mouse. In the second case, you must have turn it off since the “mouse” driver was loaded. Try to modify these two lines in /etc/X11/xorg.conf.

Replace :

Option       "Protocol" "explorerps/2"
Option       "ZAxisMapping" "4 5"

with :

Option       "Protocol" "auto"
Option       "ZAxisMapping" "4 5 6 7"


Hope it helps (but I’m not sure).

Otherwise updating HAL could solve the issue if there is a newer version which supports your mouse. (in that case you would remove the line Option “AllowEmptyInput” “off” )

He he ! interesting ! Yep! It could make a difference. The HAL daemon expects a USB mouse and you give it a PS/2. Maybe it’s not that clever to figure out your intentions.

  1. Remove the line Option “AllowEmptyInput” "off"
    from /etc/X11/xorg.conf if you were using it.
  2. Turn off your PC ( Do not unplug PS/2 when the power is on )
  3. Remove the PS/2 adapter and plug your mouse into a USB port.
  4. See if your mouse is detected now.

If you are having problems with mouse only, why don’t you customize your HAL policy files instead of messing up with xorg.conf. It is better to work with no xorg.conf if you need to adjust only mouse settings.

Connecting via USB did the trick, even the buttons to change the dpi work. Then there’s a last button of which I don’t know what it’s for, it was already that way in Windows, so everything is fine :slight_smile: .

Well, I have to give in I have no clue about HAL policy files, I’ll read about it in some time. There’s so much to learn…

Thank you a lot for your help!