Mouse and Keyboard are not working


I recently ran an “innocent” flash player. But after that, I can not use the keyboard and the mouse. This happens when linux was running, then I turn off and turn on my computer, and they (keyboard and mouse) don’t work in the login screen.

The only way I have to ask from some help and using mouse and keyboard is enetering in failsafe mode.

But for now, I can not enter in normal linux 11.1 because keyboard, and mouse died.

Also I tried to repair system from the installation disk, but mouse and keyboard, don’t work neither

Any suggestions ?

Thanks for the feebacks


Did you try another mouse or keyboard?

Even if flash messed up your X config, the bootloader should recognize the basic functions of your keyboard. If your keyboard isn’t working even at boot I’d suspect a hardware problem, with the flash thing being coincidental.

It’s not my keyboard or mouse because they work in failsafe mode.

And when I reboot from CD until I select what I want to do (included) they worked, then, they don’t work anymore.

I think I should post this issue in Install/Boot/Login forum

thanks anyway

In that case you may want to check /etc/X11/xorg.conf against one of the many backups the system does for you. Maybe replacing the mouse/keyboard sections from one of the backups will solve your problem.

This likely means they work in run level 3 (ie keyboard likely works with a text login) and you could thus boot to run level 3, run (with root permissions) “yast” and configure your mouse and keyboard under yast, which will automatically modify your /etc/X11/xorg.conf file for you.

my /var/log/boot.msg start like this:

Inspecting /boot/
Cannot find map file.
No module symbols loaded - kernel modules not enabled.

Cannot build symbol table - disabling symbol lookups
klogd 1.4.1, log source = ksyslog started.

and for that moment almost everything is an error, and I have no system.

Unless, I enter in failsafe mode.

This is taking me too long. I think I-ll format and install again, I don’t know what to do, I-m desesperate!

well… sorry, but I need my computer for work, I work alone, I I-m feeling “I cannot solve the problem in any way”

I hope you bring me a solution



Did you have any luck using “yast” per this post:

… or did you not understand how to boot to run level 3 ? To reach run level 3, all you need do, upon the grub boot menu, is press the key “3” , where 3 will be added on in the options line to the end of the current boot options. Then boot. It will take you to a text/ascii login where you can log in as a regular user, and then type ‘su’ to switch to root permissions, and then run ‘yast’ and then navigate the menu’s to configure both your keyboard and mouse.

Another thought, some PCs which have USB mouse and USB keyboard need to set their BIOS setting for USB devices to ‘legacy mode’ in order for those devices to work well under Linux.

Ok… I didn’t understand how to get a runlevel 3 at first.

But now, I’ve done, a text logis screen is displayed, but Keyboard is still dead.

thanks anyway


OK, and did you follow the remainder of my advice? ie did you check to see if you have your BIOS set to legacy mode for usb settings?

I sympathize with your problem, but its like pulling teeth to find out what recommendations you tested.

Does your keyboard work under any other operating system? or any liveCD ?

Try adding this to your serverflags section of /etc/X11/xorg.conf

Option “AutoAddDevices” “off”

And verify that you have this package installed:

rpm -qa | grep xorg-x11-driver-input

But maybe there’s too much damage and you better reinstall your system.

Yeah… It was serious.

A kernel Problem. I had to back up my files and re-install linux again. Now all it’s fine.

thanks you all!!