Mounts to NFS NAS devices very slow – making openSuse11.1 un

Hi openSuse 11.x users,

First off can I say that I’m a huge fan of openSuse, having used it and championed it since openSuse9.3. I currently have openSuse10.3 installed on over 100 machines running smoothly.

I’ve recently had to install a few openSuse11.1 machines to support new hardware. However, I’m encountering a nightmare problem with openSuse11.1 which has basically written off the OS. Even I am contemplating moving to another Linux distribution as I can’t seem to find a solution to this problem anywhere.

The problem is that on openSuse11.1 mounts to NFS NAS NetApp device volumes are very slow, taking 15 to 30 seconds to mount. openSuse10.3 mounts these same volumes instantly with no delay at all. Mounting openSuse10.3 volumes onto openSuse11.1 seems to work immediately, so there seems to be a problem with openSuse11.1 mounting non Linux NFS volumes. Once mounted everything seems to work at normal speed until the volume needs to be mounted again (when the problem reappears).

I’ve already replaced RPCBind with portmapper, as portmapper is used and works in openSuse 10.3, but unfortunately the same mounting delay occurs when portmapper is use on openSuse11.1 against non Linux NFS volumes.

I’ve also noticed on this forum that other users are encountering this problem and I’ve yet to see a solution (please let me know if I’ve missed the solution).

Our autofs map file (as pointed to from “/etc/auto.master”) has a timeouts of 600 seconds and this compounds the problem. As volumes need to be remounted regularly when users open or save files, the mount delay is making it impossible for our users to work from these NFS NAS volumes.

On our servers we also use autofs mounts with a short 120 seconds timeout (in “/etc/sysconfig/autofs”) as hard mounts have caused shutdown problems in the past. As a result, these slow mounts are encountered constantly which is making openSuse11.1 unusable for our servers.

I hope someone can suggest a solution, or something I can look into further to try and find a solution for everyone.

Neil

> I hope someone can suggest a solution, or something I can look into
> further to try and find a solution for everyone.

i hate to say it, but my guess is that the person or persons with the
level of detailed knowledge needed to help you is/are probably lurking
on usenet, in alt.os.linux.suse or similar…or maybe one of the other
“suse” web fora…somewhere…

on your note that you are contemplating moving away from openSUSE: i’m
still on 10.3 and know it is EASY to see that 9.3 was a FAR superior
system in terms of stability and dependability…

i’m hoping for a miracle with 11.2, and if it does not come i guess
i’ll go to Debian or maybe CentOS (and leave those mesmerized by eye
candy here to discuss the details of how to tweak the background image
until it too will wiggle and shimmer as the sun hits it…sigh)

that said, there is a guy in some of the fora here who enters as
ab@novell.com”…you might try to capture his attention…he may be
able to help…

good luck…and, when you decide come back and tell me what you move to…


brassy

Could disabling IPv6 name lookups and IPv6 protocols help? Have you tried doing a packet trace to see at what stage the delay happens and what the client and server are doing?

GOOD NEWS!

I think I found a solution–at least with the NFS servers I’m using (whose maps are exported with NIS). The problem appears to be with the negotiation of the mount protocol. Specifying it explicitly took my manual test mounts down from 20+ seconds to almost instantaneous. Here’s what I did:

In your /etc/sysconfig/autofs, make this modification:

LOCAL_OPTIONS=“mountproto=tcp”

Then restart autofs:

service autofs restart

Of course this assumes that all your auto NFS mounts are happy with a TCP mount protocol, but mine seem to be, even the ones that chose UDP by default. We’re using NetApp and Sun NFS servers, for what it’s worth.

Lemme know if that helps y’all!

Jeff

We are now in the same boat - previous OS was OpenSuse 10.3 and we had no issue. Upgraded to 11.2 and each NFS share takes 21 seconds to mount. We have quite a few servers that get mounted - this adds about 6 minutes to any reboot.

I have tried manual mounts as well as out of fstab file and problem remains. I have also tried using the ip address of the NFS server - no joy.
Disabling firewall also no good.
I enabled debugging in and this is what I get in messages.
Dec 2 12:43:19 sys01 kernel: [75978.044790] NFS: dentry_delete(/, 4)
Dec 2 12:43:59 sys01 kernel: [76017.668972] NFS: nfs_fhget(0:24/64 ct=1)

I also tried the recommendation LOCAL_OPTIONS=“mountproto=tcp” in the autofs config and that did not change anything.
The nfs filers are NetApp.

This appears to be an issue with the mount application - I would be very appreciative if someone official could confirm that so I can stop pulling my hair out.
Many Thanks
Steve

An update: Turns out for historical reasons we have two ips on the nfs server. If I use the first IP address to mount it has the 20 second delay. If I use the second IP it mounts instananously. So I think the nfs server was replying to the nfs client ( on my OpenSuse 11.2 box) using the second IP and the client was rejecting it - Whats odd is when this machine was running OpenSuse 10.3 it was ok with it.