mounting sdb1 so it is usable by users

Okay, I’m slowly getting my system back. I screwed up on my partitioning a bit, but it’s livable. I now have my second HDD needing to be able to be used by users (currently, it’s just me and root(me). I was hoping to use it for my programming projects and “junk” storage, but I’m not able to execute on it :stuck_out_tongue: SOOOOO, snce there isn’t anything there that is terribly important, how do I go about re-doing the mount point or whatever to make it so? Or have I completely confused you?

This isn’t really all that big a deal right now, as I can work around it for a bit. (My projects are kinda small right now as I’m re-learning what I once knew about c++, and learning NEW stuff as well.)


Yes; not sure whether the real issue is accessing sdb or mounting sdb1. Are you able to mount other partitions on sdb?

Okay, let’s see if I can clear it up a bit.:\

Currently, sdb1 is the whole drive, and it IS mounted (/local is the mount point). I’ve not TRIED to mount other partitions, but I’d first have to make them.

The problem I am/was having was in trying to use KDevelop, and using a folder on sdb1. Even as root, I kept getting errors that my searches showed to be something about no executing permissions (ie can’t run executable stuff there).

My question is how do I make it so that it IS able to execute these things? (In particular, I was getting a permission denied error when ./sh configure was called in the project folder on sdb1.)

(hope I didn’t mudy the waters even more. I am really trying to make it clear, but don’t think I am.)

Okay, I have solved this issue. I remembered seeing something about fstab in my search for the answer, so I did googled fstab, and came to this site:

How to edit and understand /etc/fstab

edited /etc/fstab to include “exec” on the drive in question, made a test project in KDevelop, and it works perfectly. I guess sometimes I just need a sounding board for some of this stuff, eh?


by default, the noexec bit is set on partitions other than the main ones so to allow execution on your sdb1 partition, you need to add ‘exec’ to the partition line in /etc/fstab … eg,

/dev/sdb1            /local          xfs        noatime,users,**exec**         1 2

You might want to look at man 8 mount a bit closer. There is a defaults option which turns on a bunch of options, namely rw, suid, dev, exec, auto, nouser, and async. You might want that auto option if it’s a non-removable disk. Also async for performance.

There are two ways you can approach it. One is to specify defaults first, and then disable the ones you don’t want:


The other is to explicitly specify the ones you want:


In any case be aware of the options in effect and what they affect.