*Mounting* samba shares in kde

I am having trouble finding a satisfactory solution to mount samba shares in kde (I know dolphin can browse them ‘out of the box’, but the problem is it doesn’t actually mount them, so you can’t for example open a video from a samba share in nautilus, because no video player on the face of the earth supports kioslaves, and I need to use mplayer anyway for tear free opengl output. I can get vlc to open video’s from dolphin after configuring vlc’s inbuilt samba module, but unfortunately vlc’s opengl output sucks: http://trac.videolan.org/vlc/ticket/7702)

I tried samba4k which worked, but it was really annoying that it asks for my password every time I mount or unmount, I want to be able to mount shares as user with no fussing over root password every time. I also tried putting a cifs mount in my /etc/fstab, but that too required root permissions so I couldn’t mount/unmount via dolphin (and I don’t really want it to mount on every boot anyway). I tried installing gigolo to see if I could achieve it with gvfs, but for some reason gigolo wouldn’t work right, it would see the share and say that it was mounted, but when i tried to open it in dolphin it would say it didn’t exist.

Is there anyway to achieve this without so much trouble?

On 2013-03-15, bwat47 <bwat47@no-mx.forums.opensuse.org> wrote:
> I am having trouble finding a satisfactory solution to mount samba
> shares in kde
> Is there anyway to achieve this without so much trouble?

The easiest way I find is enabling cifs in yast -> system -> system services (runlevel) and manually editing /etc/fstab
to include the IP address of the samba share, the mount point, and credentials. Sometimes (it seems to change from
version to version in openSUSE) I also need to throw in a `mount -a’ in /etc/init.d/after.local for the daemon to get
started properly after every reboot.

If you want to do it only occasionally, do this:

Make a script file called e.g. cifsmount.sh and put it in your personal bin folder and give it these contents

mount -t cifs -o guest // /path_to/somewhere_good

Make the file executable.

From there on gertrude can mount it with this console command, occasionally, on demand:

sudo cifsmount.sh

Alter the line “mount …blah blah…_good” to match your needs.

Managed to fix my smb4k issues by following this easy little guide: Using Smb4K on openSUSE 12.3 without password prompt | www.grim.se

Finally, passwordless on demand real mounting and unmounting of my samba shares in KDE :slight_smile: I really wish KDE did this by default, expecting all applications to support kioslaves is just stupid. /rant

I think that Samba is not there because it is most often used in a mixed Windows/Linux setup and NFS is pushed as the normal default perhaps. Be that as it may, I just want to make you aware of another solution you can find here. Could always use comments from those that use Samba all of the time.

S.A.C.T. - Samba Automated Configuration Tool - Version 1.03 - Blogs - openSUSE Forums

Thank You,