Mounting samba drive

Im having no trouble accessing my samba drive (with the smbclient), but when I try to mount it to some folder (with given username/password) it gives this error:

mount error 20 = Not a directory
Refer to the mount.cifs(8) manual page ( mount.cifs)

mount //samba.address/harald /home/harald/samba -o user=username,password=password,uid=harald,gid=users

Wrong syntax Harald, try like this:

mount -t cifs -o username=someone,password=something //samba.address/harald /home/harald/samba


Doesnt make a difference. -t cifs isnt necessary because the mount command guesses its cifs (because of // in front of the address). The -o flag can be added before or after the mount dir.

Quite true, I missed that. Have you got cifs-mount installed (suppose so).

have a look at post #6 over here:
Mount.cifs Fails With “mount Error 20 = Not A Directory” - openSUSE Forums

this fixed it for me

thx for your help