mounting all messed up... dont know what to do.

It all starts with the usual story of buying a portable hard drive that is formatted with ntfs. I read a couple things and installed NTFS config which lets me mount the drive(although having to use root password everytime is annoying).

However once I did that anytime I plug in flash stick or connect my phone now it gives permission denied. Which used to auto mount.

So I read some other posts and someone mentioned

sudo ln -s /sbin/mount.ntfs-3g /sbin/mount.ntfs

Which would is suppose to help with the ntfs auto mounting but I get a message stating

ln: creating symbolic link `/sbin/mount.ntfs’: File exists

Obviously I dont know what I am doing and it looks like I created a mess with the fragments of info I tried to pick up.
Does anyone have any suggestions?:\

Have a look at swerdna’s page
HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10, 11

The link is mount.ntfs Maybe you created it twice or more. So maybe that’s OK. Does the usb drive automount now with read-write access when you plug it in?

Nope nothing auto mounts.

ps. Yes I have tried my best to understand that site “How to mount ntfs”. That is where I got the symbolic linking command from. Evidently I don’t understand it enough.

Sorry I forgot to mention I am using openSUSE 11 with kde 3.5.9 although I do have kde 4.1 installed but that does not change the situation.

Do you absolutely need to keep the drive ntfs?

Are you using it with both windows and linux? Many will revert to FAT32 (though it is not ideal as it has limitations and fragments). Or if you only use linux, you don’t need ntfs. Use ext3.

You might have made the mistake of using ntfs-config for a portable drive. Let’s see: can you plug the drive in and then execute these commands and then copy/paste/post the results back here:

cat /etc/fstab | grep ntfs-3g

That should show if NTFS partitions are provided for in fstab

df -Th | grep fuse

That should show if any ntfs partitions are mounted anywhere

sudo /sbin/fdisk -l | grep NTFS

That should show if the operating system is aware of any NTFS partitions

So we will at least know what happens (if anything) when you plug the NTFS drive in.

I do run windoze as a dual boot and I do have ntfs partitions. NTFS is preferable on the portable drive and on top of that the drive wont let me format it with anything but ntfs.

Here is the output from

cat /etc/fstab | grep ntfs-3g

/dev/sdd1 /media/half_t ntfs-3g defaults,locale=en_US.UTF-8,force 0 0
/dev/disk/by-id/scsi-SATA_WDC_WD740GD-00FWD-WMAKE1168463-part1 /windows/C n tfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/sdc1 /media/half_t ntfs-3g defaults,locale=en_US.UTF-8,force 0 0

df -Th | grep fuse

/dev/sda1 fuseblk 35G 24G 11G 68% /windows/C

sudo /sbin/fdisk -l | grep NTFS

/dev/sda1 * 1 4462 35840983+ 7 HPFS/NTFS
/dev/sdc1 1 60801 488384001 7 HPFS/NTFS

the drive wont let me format it with anything but ntfs
WTF. Won’t let you?
Have you tried Parted Magic or similar boot disc partitioner?

I have a WD elements 500GB usb drive and it plugs and plays whatever I do with it, vfat, ntfs, ext3…

There appears to be a mixup with the “sudo ln …etc etc” thing being at odds with an entry in fstab where a temporary drive has been erroneously configured as permanently attached.

I’m having trouble getting my head around the various partitions that you have. There’s more than I anticipated and some strange results shown by your copy/paste data. Can you please describe how many physical drives you had attached at the time and what NTFS partitions were on each and for each whether it was attached internally or is portable attached by usb. A list something like this:
drive 1: internal drive, permanently attached to motherboard, with ntfs on the first partition
drive 2: etc etc
etc etc

And (with the external drive plugged in) please supply also a full listing from this form of the fdisk command:

sudo /sbin/fdisk -l

I have two 74GB WD Raptor internal hard drives.

One has no partitions and is just a stuff drive for high speed storage which is fat32.

The second drive has both linux and windows installed on it. There are 4 partitions.
-windows NTFS
-linux swap
-linux home
-linux sys/root

The external usb drive is 500 GB and is NTFS

sudo /sbin/fdisk -l

Disk /dev/sda: 74.3 GB, 74355769344 bytes
255 heads, 63 sectors/track, 9039 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x1d431d42

Device Boot Start End Blocks Id System
/dev/sda1 * 1 4462 35840983+ 7 HPFS/NTFS
/dev/sda2 4463 9039 36764752+ f W95 Ext’d (LBA)
/dev/sda5 4463 4724 2104483+ 82 Linux swap / Solaris
/dev/sda6 4725 6463 13968486 83 Linux
/dev/sda7 6464 9039 20691688+ 83 Linux

Disk /dev/sdb: 74.3 GB, 74355769344 bytes
255 heads, 63 sectors/track, 9039 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000adb02

Device Boot Start End Blocks Id System
/dev/sdb1 1 9038 72597703+ f W95 Ext’d (LBA)
/dev/sdb5 1 9038 72597672 c W95 FAT32 (LBA)

Disk /dev/sdc: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x51660837

Device Boot Start End Blocks Id System
/dev/sdc1 1 60801 488384001 7 HPFS/NTFS

OK that sorts it out for me, thanks.
You have three entries in fstab for NTFS partitions:

/dev/sdd1 /media/half_t ntfs-3g defaults,locale=en_US.UTF-8,force 0 0

The above is false because fstab shows there is no permanent drive sdd

/dev/sdc1 /media/half_t ntfs-3g defaults,locale=en_US.UTF-8,force 0 0

The above is false because fdisk shows there is no permanent drive sdc

These two false entries will perhaps/probably confuse the situation for the flash stick and phone and the external NTFS drive.

You should edit the fstab file which is located at /etc/fstab. Just delete the two lines quoted above and BTW there will be a blnak as the last line – leave it that way.

The other entry:

/dev/disk/by-id/scsi-SATA_WDC_WD740GD-00FWD-WMAKE1168463-part1 /windows/C n tfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.U TF-8 0 0

Is prima facie OK and can be left alone.

You can open the file fstab in a superuser text editor with this command ion KDE:

kdesu kwrite /etc/fstab

or in Gnome:

gnomesu gedit /etc/fstab

EDIT: ps be very careful in fstab – touch only the two lines I mentioned.

There was no sdd but I got rid of the sdc. (although I did have the portable drive off when i was doing this)

The fstab looks like this now

/etc/fstab: static file system information.

<file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/disk/by-id/scsi-SATA_WDC_WD740GD-00FWD-WMAKE1168463-part6 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_WDC_WD740GD-00FWD-WMAKE1168463-part7 /home ext3 acl,user_xattr 1 2

/dev/disk/by-id/scsi-SATA_WDC_WD740GD-00FWD-WMAKE1168463-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_WDC_WD740GD-00FWD-WMAKE1166240-part5 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0

/dev/disk/by-id/scsi-SATA_WDC_WD740GD-00FWD-WMAKE1168463-part5 swap swap defaults 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0

So what do I do now?

ps. What is that usbfs noauto?

Regarding this: “ps. What is that usbfs noauto?”
Well spotted, you should edit the “noauto” to “auto”.

Regarding: “So what do I do now?”
Now that fstab has the two spurious entries for sdc and sdd removed, and once you edit the line for usbfs, you can reboot and see if the new 500Gb NTFS drive will attach and become visible and writeable.

If it doesn’t you will then have to investigate two things:
1: whether the 500Gb drive needs to have its filesystem checked/“cleaned” in windows (chkdsk)
2: whether the links “mount.ntfs” and “mount.ntfs-3g” in /sbin are pointing to the correct targets.
But wait and see if it comes good.

So for now edit “noauto” to “auto”, reboot, attach the 500Gb NTFS drive and see how it goes.

Well the good news is that auto mounting of my phone and flash sticks are working now! Hip Hip Hurray!!

However when I plug in the usb harddrive it says

TODO: have to rethink extra options

If Linux thinks the USB drive should have its filesystem checked, it will decline to mount it. So I suggest you force a filesystem check. Yiou should have package “ntfsprogs” installed, which you can check with htis console command:

rpm -q ntfsprogs

it should return sort of like: ntfsprogs-1.13.1-80.1
One of the tools in that is “ntfsfix”. First check which device the ntfs usb drive is: run “fdisk -l” without it plugged in and “fdisk -l” with it plugged in. The difference will show you what device it is (probably sdc1). Then run ntfsfix, addressing the device like so:

ntfsfix /dev/sdc1

Then boot into windows with the device attached befor you switch the computer on and windows should run a filesystem check on it.

Then perhaps it will automount in Suse. Tell us whether chkdsk ran in windows? And whether it then mounts in Linux?

If it doesn’t then check the links in /sbin with this command:

ls -l /sbin/ntf*

This is what I get:

dell270g@suse110:~> ls -l /sbin/mount.ntf*
lrwxrwxrwx 1 root root 19 2008-08-04 21:36 /sbin/mount.ntfs -> /sbin/mount.ntfs-3g
lrwxrwxrwx 1 root root 12 2008-07-03 05:46 /sbin/mount.ntfs-3g -> /bin/ntfs-3g

What do you get?

I rebooted to windowsXp and the chkdsk did not run. So I went to mycomputer>tools for that drive and tried to run it manually, but it would not run. After the third try it said that it needs exclusive rights to the drive and asked me if I wanted it to check upon next reboot. Which I did and it said it fixed some attributes and other stuff. Once in windows again I turned the drive off and rebooted to suse. Then turned it back on but it gave the same options error

TODO: have to rethink extra options

So here is the return of:

ls -l /sbin/ntf

linux-554f:/sbin # ls -l ntf
lrwxrwxrwx 1 root root 16 2008-06-22 00:53 mkfs.ntfs -> /usr/sbin/mkntfs
lrwxrwxrwx 1 root root 19 2008-09-04 22:01 mount.ntfs -> /sbin/mount.ntfs-3g
lrwxrwxrwx 1 root root 12 2008-06-22 00:53 mount.ntfs-3g -> /bin/ntfs-3g

Are you using KDE4 Suse11.0?

I do have kde 4.1 on suse11 however I stopped using it a while ago as I realized there was a lot of functionality that I was missing. So I only use kde 3.5.9 now.

ps. Does it matter if I have gnome,xfce, and fluxbox installed as well?

It’s just that I Googled "TODO: have to rethink extra options " and found quite a few references like this:
Which point the finger at KDE4.
And over at Novell I see like this:
KDE see it as a KDE4 bug here:
Bug 157378 – HAL+NTFS-3g fails to automount ntfs drives

Now I don’t understand these things, but I got strange behavior in various things when I had both KDE3.5 and KDE4 installed concurrently. But that disppeared when I woped the install and reinstalled just Gnome and KDE3.5.9. So I found cross contamination from KDE4. But I never had your problem (lucky me). I can’t say with confidence that your manifestation is down to the presence of KDE4, but it sure does look suspicious.

BTW try logging in on Gnome and see if you get the same problem. I say this because I think that it’s a KDE bug (something to do with like kio-slave-helper).