mount usb drive on init 3

I’m trying to mount a USB drive on OpenSUSE 10.3. It’s a server so it does not have any X. Once I plug in the device I can see it in /var/log/messages :

kernel: usb 5-8: new high speed USB device using ehci_hcd and address 6
kernel: usb 5-8: new device found, idVendor=058f, idProduct=6387
kernel: usb 5-8: new device strings: Mfr=1, Product=2, SerialNumber=3
kernel: usb 5-8: Product: Mass Storage Device
kernel: usb 5-8: Manufacturer: JetFlash
kernel: usb 5-8: SerialNumber: LXLEU6MC
kernel: usb 5-8: configuration #1 chosen from 1 choice

nothing happens after that. I created a directory /mnt/usb and tried to mount it using

mount -t usbfs /dev/sdb1 /mnt/usb/ with no luck.

I also tried mounting it using all the /dev/usbdev* devices - no luck.

I am not sure how to mount this device.

The lsmod | grep usb shows

usbcore 123372 3 ehci_hcd,uhci_hcd

Thanks for any help.

Hi
It should mount under the media directory, you can confirm with the
command df -k

Else it should just mount without the -t option, besides did it get
formated as usbfs? I would have thought it’s vfat, ext3 or ntfs?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 2 days 20:26, 1 user, load average: 0.00, 0.02, 0.08
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

automount doesn’t work on init 3 so plugging in the device and typing df -k will show you nothing.

I did try mount -t [vfat, ext3 or ntfs] - but it says “unknown filesystem type ‘vfat’”

Wondering why it’s so hard to mount a simple flash drive on Linux distributions!

Hi
Ahh Ok :), fdisk -l after it’s plugged in should show you the type and
also the device (just to make sure it’s sdb1?).
I just tried my flash disk at runlevel 3, but didn’t have to use the -t
option to mount.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 2 days 23:27, 2 users, load average: 1.11, 1.00, 0.57
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

I agree: the first step has to be fdisk -l to be suse that the device node is sdb then we have also to check the partitioning scheme. So if the device is sdb then run fdisk /dev/sdb and when you get the fdisk’s command line enter p . It will print the partition table and the file system type. Then you can mount the partition of your interest with the usual command.

fdisk -l does not show the disk. It doesn’t show anything called /dev/sdb either. It shows /dev/sda1-5 - these are my system partitions.

I tried with and without the mount -t option - no luck.

Thanks for any further help.

Hi
So, dmesg still shows it plugging in? Now I wonder if it’s something to
do with the “JetFlash” device, wonder if it has a hidden window
partition to kick in a driver?

If you think it’s sdb, can you try fdisk /dev/sdb (just sdb, no
partition reference number) to see if you can get to it and use the
‘p’ option to display the info?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 3 days 8:54, 2 users, load average: 0.00, 0.12, 0.19
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

So now i suspect that something went wrong with the partition table. This happened to me with a 4GB pendrive. I solved this with a windows pc, performing a scandisk, choosing the automatic repair. I hope that this helps you too.