mount tmp on tmpfs not working

Hi, I would like to mount /tmp to tmpfs.
the way to do this today is via systemd,

[a4z@t460p ~] > systemctl is-enabled tmp.mount

[a4z@t460p ~] > df -k /tmp
Filesystem     1K-blocks    Used Available Use% Mounted on
/dev/sda6       41946112 9778212  31893644  24% /tmp

I used the howto from here

why does it not work?

I have this entry in my /etc/fstab

tmpfs		/tmp	   tmpfs	size=25%,uid=root,gid=root,mode=1777 0 0

The 25% is of course something you should choose.

yes, thanks, this is of course the ‘old style’ approach,
but systemd should manage this today, but it does not work on opensuse,
what I remember, in former days I used openSuse, the tmpfs option could be set in yast via system settings or so,
however, today the systemd way ‘should’ work … I know it works on rhe7 with systemctl enable tmp.mount since I did in at work today

I do not know about the systemd way (it looks as if systems claims to do everything), but imho a reboot is required between switch such a thing on and it being active.