mount shared folder in fstab using Vbox 4.2.18 opensuse 13.1 guest machine = FAIL

this failure is at boot with systemd warnings then a complete hang.

remove the fstab entry in the guest and the guest starts fine and the share folder can be mounted without incident…and yes the fstab entry is proper and works perfectly in other guest machines i.e. two other opensuse 12.3 guests, both having vitrualbox guest tools 4.2.18.

some investigation at suggests that there is a problem with the 3.11 kernel and versions previous to 4.2.22 but the way i read the bugreports the shared folders won’t mount manually either which is not the case with me.

i am handcuffed to 4.2 for the time being and need a workaround, hopefully someone has had the same problem and can advise…

thanks in advance :slight_smile:

If fstab wont work for you with systemd then you can probably write your own unit file ( files with *.service in it) and run the mount command manually. Since you are stuck with that vbox version then i don’t see any other option. Well some folks might know some cool tricks though :slight_smile:

The documentation is obsolete.
You should never add a shared folder in fstab, you should instead modify the Share Folder properties in the Guest’s Settings, check “automount”