mount problem


I just installed openSuse 11.1 with kde4.1 and noticed some things working differently from other distros I have used before.

I wanted to mount some partitions so I try dolphin (dolphin has on default hdds on left side of an open window) and it said:

An error occured while accessing 'Volume (ext3)', the system responded:
org.freedesktop.Hal.Device.PermissionDeniedByPolicy: auth_admin_keep_always
<-- (actoin, result)

does that mean I have to change some settings in openSuse or hal-system-storage-mount? Im completely lost on that one.

Also when I try to mount normally (from terminal) it will give me strange results. It just hangs without any feedback, so I have to ctrl+c it… but that doesnt work, forcing me to close the terminal or open new tab.

# mount /dev/sda1 /mnt

Then all is ok except that the mount failed… and this

$ cd /
$ ls

Now I cannot find the content of / but I see that there is a /
After that I cannot open anything on the panel (menu, window switcher, workspaces…)

I had the error message you posted until I installed and ran:

NTFS-3g & NTFS-Config from Yast

Hi. Please post the output of “fdisk -l” and “mount” and maybe your /etc/fstab as well.
When you mount a volume don’t mount it to /mnt but to a subdirectory of /mnt or anywhere else. You will have to create this directory before mounting. Then you need to specify the filesystem with -t in the mount command. For an ext3 partition:

 mount -t ext3 /dev/sda1 /mnt/something

And for ntfs:

 mount -t ntfs-3g /dev/sda1 /mnt/something


oh insertCurseWords I forgot to say that the partitions are not selected to be auto mounted, so by default they should not be in fstab.

fdisk does not work for some reason

fdisk -l
fdisk: command not found

I did not think of having type as flag :’( but it works perfectly after making a folder with me as a user and 777 rights, with the standard 731 (rwxr-xr-x ) dolphin didn’t display any files even though I could ls everything on the terminal.

So thank you very much for your help.

now I just have to find out why it doesnt mount from dolphin (and why I cannot run dolphin as super user). but Im happy I have always just used scripts to mount partitions any way


fdisk does not work for some reason

Only root can run fdisk on openSUSE. And I think only root can mount volumes.

indeed. that is why I was trying to launch dolphin as root.

$ is user and # is root in standard bash prompt isn’t it? I am confused why this isn’t in opensuse

how do I mark the thread as solved?

See KDE4: USB stick access fails with Hal.Device.PermissionDeniedByPolicy there’s no need to be root to mount a USB pen drive etc.

Sorry to bump this old thread, but I got the error mentioned by the op when trying to access my NTFS volumes in a new installed of openSUSE 11.1.

I solved this by simply installing and running ntfs-config from the repo. It took me 30 seconds to enable write access on the two partitions I needed to use and it works perfectly as Maestro said. A happy bunny am I! :slight_smile:

Anyway, I thought I’d mention this in case it helps anyone else.


Yeah I am getting this issue too. The ntfs-config way works but it generates an fstab entry instead of using dynamic mounting through HAL.

I think there’s a bug in Dolphin’s integration with PolicyKit in opensuse. The default implicit authorizations should cause Dolphin to prompt for a root password upon mounting (this is the way it works in Kubuntu), but this dialog is not displayed. Dolphin never gets authorization so fails with the PermissionDeniedByPolicy error.

The quick workaround is to grant yourself explicit policykit permissions using the PolicyKit-kde tool in System Settings->Advanced. Find and add yourself to the user list.