mount pen-drives and cds

hello. i jus migrated from Ubuntu to openSUSE 11.1 on my desktop. N nt was i disappointed by the automatic mounting of pendrive/cdrom, I really can’t get it working. Need help real bad.
Thanx!:’(

I found this in a sister forum. it might help, yet i haven’t tried it myself yet (working currently on xp) because i’m having & investigating the very same issue. Check my post on the topic: ]no device cdrom - openSUSE Forums](http://forums.opensuse.org/hardware/405056-no-device-cdrom.html#post1928212)

hope it helps and let me know whether it worked or not.

<OF>


Question
USB mounting problem in 11.1
Until today openSuSE 11.1 seemed to work just perfectly. However, as of today (I don’t know why - maybe an update?) my USB devices are not mounted automatically.

If I plug in a USB drive, the device notifier tells me that there is a new device but it has no mount point. If I click on the icon in the device notifier widget, it takes a long time before I get an error in the bottom of the Dolphin screen.

If I go to /media as root, then I have the not mounted folder for the USB drive and two files: .hal-mtab~ and .hal.mtab-lock

.hal.mtab~ contains:

Code:
/dev/sdc1 1000 0 vfat nosuid,nodev,uid=1000,utf8 /media/UDISK 2.0

and .hal.mtab-lock is empty. Does anyone have the same problem or does anyone know a solution? Ideas?

By the way, I don’t know if this is related to this problem, but when shutting down, the computer takes an awful lot of time trying to unmount fuse control filesystem, which eventually fails. It also says that / is busy.

Answer:
Run as root and all should be back to normal:
Code:
polkit-auth --grant org.freedesktop.hal.storage.mount-removable --user <your username here>


ah…thanx a lot man! ur my savior. im in ur debt!!lol!

Can anyone tell me the best place to find information on the policy changes in the new KDE desktop with the requirements for “polkit-auth”? I just want to read up on the reasons for the security changes…

Thanks…

Hi,
Is there a file somewhere with which this is associated? I’d like to know what current permission are and how I can change them. Thanks