mount option 'user' does not work in /etc/fstab

I have a item

firefox /home/xxx/.mozilla/firefox/vzc8wcet.default tmpfs size=400M,noauto,user,exec,uid=1000,gid=100   0  0

in /etc/fstab .
But every time 12.3 startups , it always mounts it automatically .

I can not use ‘mount firefox’ with ordinary user to mount it .

What is the matter ?
Thanks

On 03/26/2013 05:26 PM, waterloo2005 wrote:
> What is the matter ?

you completely confused me…what is it you are trying to do?

it seems you have a device you want to be named ‘firefox’ which you
wish to manually mount at /home/xxx/.mozilla/firefox/vzc8wcet.default
sometimes AFTER boot…is that correct?

or am i far off?

and, you are right an ordinary user can’t mount…only root can do
that…

i really think you need to explain what it is you want to do…


dd
http://tinyurl.com/DD-Caveat

dd wrote:
> and, you are right an ordinary user can’t mount…only root can do that…

well, except that the OP showed us a ‘user’ option in the fstab as well
as the ‘noauto’ option!

He is trying to mount a tmpfs file system on top of his firefox profile directory.

That’s an interesting privacy move, particularly if he is using encrypted swap. All local evidence of his browsing disappears without a trace on reboot.

For “tmpfs”, the device field seems to be just a filler, so he is using “firefox” as a comment to identify what he is doing.

I suppose one could use firefox normally for a while. Then shut it down, mount the tmpfs, and restart firefox to browse porn or online gambling or whatever. (I’m merely giving illustrations there).

I suppose once could achieve the same effect by creating a second firefox profile. In that case, allow the mounting at boot. Use the main firefox profile for normal browsing, and the alternate firefox profile for whatever browsing one wants to keep very private.

On 03/26/2013 05:47 PM, Dave Howorth wrote:
> except that the OP showed us a ‘user’ option in the fstab as well
> as the ‘noauto’ option!

hmmmm…i am not (always) blind…but my seeing-eye-dog did take a
nap about a half hour ago!!


dd

nrickert wrote:
> For “tmpfs”, the device field seems to be just a filler, so he is using
> “firefox” as a comment to identify what he is doing.

Then again, if the device field really does mean something, perhaps that
is the reason that the system appears to be ignoring the fstab entry.
I’d say go look in the logs, but I’m not sure which log. And I’d
certainly say try a manual mount with a -v or two to see what is happening.

On 03/26/2013 06:16 PM, nrickert wrote:
> restart firefox to browse porn or online
> gambling or whatever. (I’m merely giving illustrations there).

oh! hmmmm…i know what ‘gambling’ is, but what is a ‘porn’?


dd :slight_smile:

I mount firefox to tmpfs for fast speed .
I want to know :
I have used ‘user’ and ‘noauto’ parameters in fstab. Why will openSUSE mount that item automatically ?
Why does not openSUSE permit ‘mount using ordinary user’ ?
Thanks

On 3/26/2013 1:05 PM, dd wrote:
<snip>
> oh! hmmmm…i know what ‘gambling’ is, but what is a ‘porn’?
>

You’ll know it when you see it. :wink:

P.V.
“We’re all in this together, I’m pulling for you” Red Green

Those are two different issues.

As best I can tell, your problem is with “noauto”.

As a test, I added a similar line to my “fstab” file. I was able to mount and umount as an ordinary user. So I think the “user” parameter is being honored.

As best I understand things, the “user” parameter is looked at by the “mount” and “umount” commands. And the “noauto” parameter is handled by “systemd” during startup.

So I think you have found a bug with “systemd”, and it needs to be reported.

I actually have some file systems with “noauto”, and they are working properly for me. But they are not “tmpfs” file systems. It might be that “systemd” handles the regular file systems in its first pass, and the “tmpfs” file systems in a later pass. And, based on your post, it looks as if the “noauto” option is not being checked for “tmpfs” file systems.

I recommend that you file a bug report.

On 03/27/2013 05:02 AM, PV wrote:

> You’ll know it when you see it.

supremely said!


dd

Like others say (and unlike you seem to think and unlike the title of this thread), it is not the user option, but the noauto option that is ignored.

And when it is already mounted “by the system”, then the user option becomes meaningleess.

To prove this and to make the case more clear for reporting a bug, test without the user option (but of course with the noauto option) to show that noauto is ignored in the tmpfs case.

I make a mistake.

firefox /home/xxx/.mozilla/firefox/vzc8wcet.default tmpfs size=400M,noauto,user,exec,uid=1000,gid=100   0  0

Between ‘default’ and ‘tmpfs’ , there is a ’
’ .
After I delete ’
’ , it is OK.

Eh-eh. That is why we ask to realy copy/paste from terminal direct into the post. But in this case I thought this was because already on the termiinal the line was broken because of it’s length.