Mount of /home takes a long time

Hi everybody -

I am experiencing a very long boot time (about 2 min) using OpenSuSE 12.1 on a fairly fast desktop computer. Taking a look at the bootchart, the problem seems to be at the mount of /home (it takes about 90 seconds). Here is my fstab:

/dev/disk/by-id/ata-TOSHIBA_MK1032GSX_Y5AK5007S-part6 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-ST9500325AS_5VEJ2NEW-part3 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-ST9500325AS_5VEJ2NEW-part1 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-ST9500325AS_5VEJ2NEW-part4 /home                ext4       nofail                1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

Any suggestion?

Thank you very much

On 08/03/2012 09:06 AM, Cpedone wrote:
> /home ext4 nofail 1 2

where did that “nofail” come from?

i would try it with either “defaults” or “acl,user_xattr”


dd

Thank you. I replaced the “nofail” with “acl,user_xattr” and actually /home gets mounted in less than one second. The total boot time, however, is still about two minutes: now it gets stuck for about 90 seconds at “systemd-tmpfiles-setup-service”. ???

> "systemd

you didn’t answer my question: “where did that “nofail” come from?”

[if you don’t answer my question why should i answer yours??]

maybe this will help, maybe not:

at the first green screen press F5 and select “System V”, like here
http://tinyurl.com/c6rpdn6 and here
http://dl.dropbox.com/u/10573557/12.1_Misc/12.1_F5_sysV.jpg

have you run YaST Online Update yet?


dd

Sorry about not answering your question… it’s just that I have no clue about where the “nofail” came from. I think it was an automatic setting at installation, I don’t remember messing with fstab (on this installation :wink: ). I tried F5 at the first green screen, but nothing happened, the boot went on as usual. I haven’t run YaST Online Update, guess I should try that now. Thanx.

On 08/03/2012 12:16 PM, Cpedone wrote:
>
> Sorry about not answering your question… it’s just that I have no clue
> about where the “nofail” came from. I think it was an automatic setting
> at installation, I don’t remember messing with fstab (on this
> installation :wink: ).

yes, i was trying to find out if you had changed it…very strange
that i showed up there…if you didn’t change it then i have to wonder
if maybe your install media is broken and that is the reason for your
problem!:

> I tried F5 at the first green screen, but nothing
> happened, the boot went on as usual.

really??? that is VERY strange: if you press the F5 key as soon as that
first green screen comes up [the one where you can choose to boot
Failsafe or Desktop or (maybe) something else (like Windows)] you should
immediately be given the options shown in the links i gave, see here:
http://tinyurl.com/systemV

if that is not happening you got much bigger problems than a two minute
boot–by the way, what do you expect? (i’m very happy with my ~90
second boot!! being able to throw up what looks like a desktop [but
can’t be used because loads of stuff is still being loaded and a click
is not resonded to for 15 seconds] doesn’t count much for what i want: a
usable and nimble desktop ready to rock and roll!!)

> I haven’t run YaST Online Update, guess I should try that now. Thanx.

could be a help.


dd

Hi -

I run Online Update, to no avail… Others suggestions?

Thanks a lot

CP

Hi -

Yes

  • did you checksum (md5 or sha1) test the downloaded iso prior to
    burning the disk

Yes.

? The link does not work

if you press the F5 key as soon as that
first green screen comes up [the one where you can choose to boot
Failsafe or Desktop or (maybe) something else (like Windows)] you should
immediately be given the options shown in the links i gave, see here:
http://tinyurl.com/systemV

There’s definitely something strange here. The GRUB options from where I choose which OS to boot look completely different from your screenshot: they are on a terminal-like black screen, all the options I get those needed to change the boot options using the command line.

-by the way, what do you expect? (i’m very happy with my ~90
second boot!! being able to throw up what looks like a desktop [but
can’t be used because loads of stuff is still being loaded and a click
is not resonded to for 15 seconds] doesn’t count much for what i want: a
usable and nimble desktop ready to rock and roll!!)

I see your point here, but on my older installation I had a ready-to-use system in less than 1 min. I am just trying to understand what is going on…

Thank you.

On 2012-08-03 10:46, Cpedone wrote:
>
> Thank you. I replaced the “nofail” with “acl,user_xattr” and actually
> /home gets mounted in less than one second. The total boot time,
> however, is still about two minutes: now it gets stuck for about 90
> seconds at “systemd-tmpfiles-setup-service”. ???

Maybe the log has something to say about it.
Who wrote that “nofail” there? It is very strange.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Hi Carlos -

I have no clue about where the “nofail” came from. I think it was an automatic setting at installation, I don’t remember messing with fstab (on this installation :wink: ). At any rate, changing the “nofail” with “acl,user_xattr” solved the problem with respect to the time required to mount /home, but now the boot takes forever at a later step (from bootchart: systemd-tmpfiles-setup-service).

Thanks

CP

On 08/03/2012 01:16 PM, Cpedone wrote:
>> - did you do this prior to install: ‘Picasa Web Albums - carl fletcher -
>> 11.4_DVD_Install’ (http://tinyurl.com/3qde66h)/
>
> ? The link does not work

that link works fine here! which is another hint that you have a very
broken system (i think)

try this one: http://tinyurl.com/455hbml
or this one: http://tinyurl.com/cj94x8d

if you didn’t do the “Do this first” before you installed: do it now!
and if the disk doesn’t check out you need to throw it away (or use as a
‘coaster’) and try again…

>> immediately be given the options shown in the links i gave, see here:
>> http://tinyurl.com/systemV
>
> There’s definitely something strange here. The GRUB options from where
> I choose which OS to boot look completely different from your
> screenshot: they are on a terminal-like black screen, all the options I
> get those needed to change the boot options using the command line.

so, i see you have (for example) “bootchart” and speak of “my older
installation” and i wonder what the older install was, and how you got
to 12.1? that is which supported (known to work correctly) method did
you use to move from what version to 12.1?

pick one:

  1. http://tinyurl.com/35p966c
  2. http://tinyurl.com/6kvoflv
  3. http://tinyurl.com/7l4m2td

no fair saying you did half of one then a little of another one, and
them made up some (it REALLY is beginning to sound like you got
creative…and . . .)

> I am just trying to understand what is going on…

my current guess is: badly broken system…maybe even with mixed and
conflicting software…


dd

On 2012-08-03 13:16, Cpedone wrote:

> There’s definitely something strange here. The GRUB options from where
> I choose which OS to boot look completely different from your
> screenshot: they are on a terminal-like black screen, all the options I
> get those needed to change the boot options using the command line.

Then you have to create a new entry in the grub menu.lst file, and change it a bit:


kernel /boot/vmlinuz... init=/sbin/sysvinit  root=/dev/dis....

And you may post a new question about your grub in text mode.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

The media check is fine. I used to have OpenSuSE 11.4, then I made a fresh installation of 12.1 from a CD. It looks like I should reinstall it (from what you say, evidently something has gone wrong). It’s a pity, though, because apart from the slow booting the systems seems to work perfectly well. Should I decide to reinstall it, is there a way to save the list of the software I installed (e.g. LaTex) and then reinstall all the packages in batch?

Thank you

CP

On 08/03/2012 05:56 PM, Cpedone wrote:
>
> The media check is fine. I used to have OpenSuSE 11.4, then I made a
> fresh installation of 12.1 from a CD. It looks like I should reinstall
> it (from what you say, evidently something has gone wrong). It’s a pity,
> though, because apart from the slow booting the systems seems to work
> perfectly well. Should I decide to reinstall it, is there a way to save
> the list of the software I installed (e.g. LaTex) and then reinstall all
> the packages in batch?
>
> Thank you
>
> CP
>
>

hey, if you are happy except for the boot time: YOU need to decide what
you want to do…not me.

the following two ‘tips’ i find saved to my long list of stuff…they
may work, they may not–read my sig’s caveat before doing anything i
seem to suggest:

  1. this will make a complete list of what you have installed

rpm -qa --qf '%{NAME}:%{VERSION}:%{RELEASE}:%{INSTALLTID}:%{SUMMARY}
'
| sort
  1. to save all installed apps to reinstall after disaster

## export list to a .txt-file
rpm -qa --queryformat '%{name}
' | grep -v gpg-pubkey | tr '
' ' ' >
apps.txt

## replay applications
zypper in $(cat apps.txt)
it works, I have done that several times.

i think #1 came from hcvv and #2 from my buddy gropiuskalle


dd http://tinyurl.com/DD-Caveat

A lurker’s comment. Yesterday I happened to notice “nofail” in the system where I had just installed 12.2 RC2. I have no idea how it got there. It was presumably added by the installer, though it might be from an earlier install, then copied forward because I imported the partitioning.

In my case the “/home” is an encrypted partition, so perhaps the “nofail” indicates to keep retrying in case the crypto has not been done on the first try.

Thanks everybody for the suggestion. All in all, I think I’ll wait until 12.2 is out and then I’ll have it installed from scratch… it’ll be a lot of fun!

Best

CP

On 2012-08-03 17:56, Cpedone wrote:
>
> The media check is fine. I used to have OpenSuSE 11.4, then I made a
> fresh installation of 12.1 from a CD. It looks like I should reinstall
> it (from what you say, evidently something has gone wrong). It’s a pity,
> though, because apart from the slow booting the systems seems to work
> perfectly well. Should I decide to reinstall it, is there a way to save
> the list of the software I installed (e.g. LaTex) and then reinstall all
> the packages in batch?

Yes… it is called autoyast. If you do a yast backup, one of the things it does is create an
autoyast file that can be used to reinstall the system again. I have never done it, so I don’t
know what the exact procedure would be.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On 2012-08-03 19:36, nrickert wrote:
>
> dd@home.dk;2478023 Wrote:
>> you didn’t answer my question: “where did that “nofail” come from?”
>
> A lurker’s comment. Yesterday I happened to notice “nofail” in the
> system where I had just installed 12.2 RC2. I have no idea how it got
> there. It was presumably added by the installer, though it might be from
> an earlier install, then copied forward because I imported the
> partitioning.
>
> In my case the “/home” is an encrypted partition, so perhaps the
> “nofail” indicates to keep retrying in case the crypto has not been done
> on the first try.

In the case of encrypted partitions, nofail is needed. The crypto device can be enabled (by
password, or not. In the case the password was not given the system would try to mount it when
fstab is read later - and as the crypto device would not exist, it would fail. The boot process
would halt and dump you in rescue mode… and baffled why.

Thus the “nofail” so that fstab reading process will not fail if the password failed.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Read that http://suse.gansert.net/?p=38
(and you need package autoyast2 installed)


PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

as far as I remember (I did it once and was a while ago) and rereading
the blog post I linked previously:
the correct command to get the list you want is


su -
zypper in autoyast2 #to get the package for autoyast
yast2 clone_system modules clone=software

how to apply the resulting xml file to your newly installed system is
described in Gansert’s blog (ayast_setup).


PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10