Mount new HDD

I have added a third disk to my PC. Using Yast, I created a partition table (I have tried GPT and MBR), created a 1TB
partition, formatted as ext4, and mounted it. The disk mounted, I can access it, but the hard disk LED blinks permanently,
approx 2 per second. Consequently, the computer slows down. I have tried it with other disks, with the same result.
Any ideas?

Reproducible: Always

It might be baloo indexing the disk if it has data on it. Usually when it runs first time it scans the entire disk system in one go. There after it updates.

There can also be a problem due to the way ext4 works but in my case it was accessed every 5 secs. That can be improved by adding noacl to the disks options in fstab. What seems to be happening is that things like browsers are updating a disk all of the time so ext4 is for ever journalling.

When I noticed that this was going on I came across a comment on the web that initial formats may be incomplete and are finished off when the disk is actually running. I’ve seen no signs of this on open suse though.

Your problem was reported as a bug some years ago - slowing the machine down. Later it was just reckoned to be just down to how ext4 is supposed to work. At that time ext3 didn’t cause the same problem. People were having problems getting the disks to power down for power saving on laptops. That may have been fixed now but the solution was to extend the journalling write time very significantly. Using ext3 seems a better solution to me.

So in summary if the machine carries on doing it when it’s idle maybe just waiting for it to stop will get rid of the problem.

Baloo can be set back to do a first run again via ~/.config/baloorc by changing initial indexing… = true to false however you need to disable it first and delete it’s current cache file. It can be disabled in start button-system settings-search-file search. You can also disable some of plasma search here but must leave one enabled - that has to be a bug.

If you still have bookmark searches active a recent post I made shows how to fix that.

The reason for needing to do this seems to be down on going work. However having disabled the lot other than aspell plasma search krunner is now completely and utterly dead but the start button menu does search out applications and currently nothing else.

I reset all of my baloo some time ago as indexing everything in my case isn’t a good idea so I have totally disabled the lot. Then when I have time I will bring some of it back up excluding some directories etc. I deleted it;s cache file some time ago so not 100% sure where it is but think it’s in ~/'local/share/baloo. Easy for me to find as I just searched for files over 1gB.


Thanks for the reply - I’ll try it out and see what happens

No go, I’m afraid. I’ve noticed something else - when the new disk is mounted, the hard disk leds on my server (proxy) and on my hub switch blink, as if it was looking for a software package from the repos or something similar. Maybe some specific package is missing or damaged any idea on which packages(s) I should re-install?

Show fdisk -l and /etc/fstab and maybe you should run smartctrl and fsck on the new disk to be sure all is healthy.

Mounting a new drive/partition is seldom a problem so no need for extra stuff

I suspect it may just be down to using ext4 and is caused by journalling. iotop can be used to see what is causing the writes and on my system showed journalling writes every 5 secs until I added the option to fstab.

This is what I get now

dhcppc1:/home/john # iotop -obtqqq | grep jbd2
08:38:47  1046 be/3 root        0.00 B/s    0.00 B/s  0.00 %  0.03 % [jbd2/md0-8]
08:38:48  1046 be/3 root        0.00 B/s    7.67 K/s  0.00 %  3.00 % [jbd2/md0-8]
08:39:07  1098 be/3 root        0.00 B/s    3.79 K/s  0.00 %  2.52 % [jbd2/sdb2-8]
08:39:14  1046 be/3 root        0.00 B/s   11.59 K/s  0.00 %  3.04 % [jbd2/md0-8]
08:39:27  1098 be/3 root        0.00 B/s    3.85 K/s  0.00 %  2.19 % [jbd2/sdb2-8]
08:39:35  1098 be/3 root        0.00 B/s    3.86 K/s  0.00 %  2.19 % [jbd2/sdb2-8]
08:40:27  1098 be/3 root        0.00 B/s    3.84 K/s  0.00 %  2.41 % [jbd2/sdb2-8]
08:41:28  1098 be/3 root        0.00 B/s    3.86 K/s  0.00 %  1.83 % [jbd2/sdb2-8]
08:41:57  1098 be/3 root        0.00 B/s    7.73 K/s  0.00 %  3.23 % [jbd2/sdb2-8]
08:42:02  1046 be/3 root        0.00 B/s   46.56 K/s  0.00 %  3.86 % [jbd2/md0-8]
08:42:23  1046 be/3 root        0.00 B/s    0.00 B/s  0.00 %  3.84 % [jbd2/md0-8]
08:42:27  1098 be/3 root        0.00 B/s    3.88 K/s  0.00 %  2.12 % [jbd2/sdb2-8]
08:42:37  1046 be/3 root        0.00 B/s   34.86 K/s  0.00 %  3.86 % [jbd2/md0-8]
08:42:53  1046 be/3 root        0.00 B/s    0.00 B/s  0.00 %  3.37 % [jbd2/md0-8]

sdb2 is /var. I can’t hear those writes so clearly. Md0 is my /home directory. The increase in activities on that is due to leaving it running while I typed this post. It’s not been possible to detect what is actually causing the writes in my case. This came up while i was typing this paragraph. The repeat interval increased once I had finished it.

dhcppc1:/home/john # iotop -obtqqq | grep md0
08:48:00  1046 be/3 root        0.00 B/s   50.38 K/s  0.00 %  4.01 % [jbd2/md0-8]
08:48:09  1046 be/3 root        0.00 B/s   11.60 K/s  0.00 %  4.01 % [jbd2/md0-8]
08:48:15  1046 be/3 root        0.00 B/s   11.59 K/s  0.00 %  3.11 % [jbd2/md0-8]
08:48:24  1046 be/3 root        0.00 B/s    0.00 B/s  0.00 %  3.18 % [jbd2/md0-8]
08:48:39  1046 be/3 root        0.00 B/s   34.26 K/s  0.00 %  2.99 % [jbd2/md0-8]
08:48:54  1046 be/3 root        0.00 B/s    0.00 B/s  0.00 %  3.96 % [jbd2/md0-8]
08:49:01  1046 be/3 root        0.00 B/s    7.68 K/s  0.00 %  3.06 % [jbd2/md0-8]
08:49:10  1046 be/3 root        0.00 B/s   34.56 K/s  0.00 %  3.85 % [jbd2/md0-8]
08:49:25  1046 be/3 root        0.00 B/s    0.00 B/s  0.00 %  3.39 % [jbd2/md0-8]
08:49:35  1046 be/3 root        0.00 B/s    0.00 B/s  0.00 %  3.16 % [jbd2/md0-8]

It looks to me like it’s accessing for no reason at times. Probably to check what it’s done.

Quick question that relates. I could use iotop as an ordinary user. I can’t now. How can I get that back?



It seems that you missed this request:

At least the fdisk -l and the fstab (and maybe


needed to see what you use the partitions for.

iotop shows ext4lazyinit on top


Interesting. This may explain why I am having a problem installing a new disk. Doubt it but something to look at.

Must admit though due to the write frequencies I am no getting I’m going back to ext3 in the hope that this stops.


ext4lazyinit was the problem! Creating a new partition with default settings /Yast) does not initialise all inodes, so that on the first mount, ext4lazyinit does this, albeit very slowly. A 1 TB partition can take ages. I finally did it with 'mkfs.ext4 -E lazy_itable_init=0,lazy_journal_init=0 /dev/xxx.

Maybe this can help others - thanks for help anyway.

Ivan Russell

Thanks Ivan. It might help with a problem I have. I’m changing a disk with /var and /tmp on it plus swap. I’ve disabled swap for a while as that complicates things and easily bought back with YAST but when I boot up with the disk in the kernel comes up with a job running on the disk message. That doesn’t finish and as a result I boot to the console. This is a 1TB disk too. Could be that the lazy format is part complete and flagged as active. I doubt it though as boot needs to be able to cope with that but maybe only a part of a single lazy format had been done.

:’(Or something needs to be in /var that was put their during the previous boot on the old disk.

On the general area of writes I came across a comments about mounting log to ram, tmpfs. Also using ext2 for flash drives.