Mount Error 12 when Mounting a CIFS share.

We recently moved to a new home and I am trying to get my home file/print server set up again. Thanks to swerdna’s excellent website, I got my server box (just upgraded from 11.0 to 11.2) running Samba and serving my shares over the network, and my “client” machines can access them without a problem.

However, I’m not having much luck setting up CIFS mounts on my Linux desktop. I have my all-purpose user added to the Samba auth list (via smbpasswd), and configured my client as swerdna’s howto’s specify, and I can access the files just find. However, when I try to mount the shares with this command:

mount -t cifs -o username=klein,password=klein // /home/zak/SharedMedia/

I get the following error:

mount error(12): Cannot allocate memory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I Google’d for this a bit, and found quite a few others with similar problems, but all of them where mounting shares on Windows machines, and as the problem is apparently a server-side issue, the “fixes” mostly consisted of Windows Registry hacks. Not very helpful, of course…

I’m not sure what to try next. I’ve tried restarting nmb and smb (and smbfs), rebooting, etc etc. I’m guessing I’ve misconfigured something somewhere, but obviously I don’t know where or what. Any ideas?

Here’s the relevant (I hope) lines from smb.conf:

        workgroup = KLEINET
        netbios name = servant3000
        name resolve order = bcast host lmhosts wins
        passdb backend = tdbsam
        printing = cups
        printcap name = cups
        printcap cache time = 750
        cups options = raw
        map to guest = Bad User
        include = /etc/samba/dhcp.conf
        logon path = \\%L\profiles\.msprofile
        logon home = \\%L\%U\.9xprofile
        logon drive = P:
        usershare allow guests = Yes
        local master = yes
        preferred master = yes
        os level = 65


        comment = Shared Media
        inherit acls = Yes
        path = /srv/media
        read only = No

Not sure what else would be helpful.

Looks like I spoke to soon on my progress. Turns out that while I can view the Samba shares from client machines, I can’t access the files, I get prompted for a username/password, and after a answering dozen or so prompts with a valid username/password (both for the Samba server pdb and the actual remote OS user), I get an “Access Denied” message. I went over the tutorial again and I can’t see where I went wrong.

I got this error, because the mounted share was empty. Under Ubuntu, but should not be different.