mount and access trouble

I have multiple drives mounted where I want them but all the permissions say owner root / user root
I can view content but can not add files, open files, or move or delete files on these mounted drives.
I am listed as member of root, users,vitualboxusers

So why can’t I have full access??

bootefi → /dev/sda1
swap → /dev/sda2
/ → /dev/sda3
/home → /dev/sda5 ext4 full access
/home/rick/e-drive → /dev/sda4 NTFS read only
/home/rick/special → /dev/sda6 ext4 read only
/run/media/rick/other → /dev/sda7 ext4 read only
/Programing -->/dev/sda8 ext4 read only

using df

rick@linux-bdgk:~> df
Filesystem     1K-blocks      Used Available Use% Mounted on
devtmpfs         2978324         0   2978324   0% /dev
tmpfs            2986636         0   2986636   0% /dev/shm
tmpfs            2986636      9836   2976800   1% /run
tmpfs            2986636         0   2986636   0% /sys/fs/cgroup
/dev/sda3       30439332  13413980  15436104  47% /
/dev/sda1         307016      8552    298464   3% /boot/efi
/dev/sda6       72123712  60023328  11056284  85% /home1
/dev/sda5      133123628  82059888  44231780  65% /home
/dev/sda4      636550368 464382976 172167392  73% /home/rick/e-drive
tmpfs             597324        16    597308   1% /run/user/1000
/dev/sda7       30832548     45080  29198220   1% /run/media/rick/otherOS
/dev/sda8       61665068     53280  58449676   1% /Programing

using cat /etc/fstab

rick@linux-bdgk:~> cat /etc/fstab
UUID=331eace0-f7c9-4732-8ff0-129ee08774b4  /                   ext4  acl,user_xattr  0  1
UUID=282757a6-8ba5-4c28-8b0d-c275b7a19699  /home               ext4  acl,user_xattr  0  1
UUID=FA40-B0B4                             /boot/efi           vfat  defaults        0  0
UUID=2d7dbe3d-bd50-40b6-b222-080e09505c79  /home1              ext4  defaults        0  2
UUID=ABC9-795A                             /home/rick/e-drive  vfat  defaults        0  0
UUID=df65f5a3-de2f-428a-80f2-cd0416e4a749  /Programing         ext4  defaults        0  2

For the “ext4” drives, ownership is part of the file system. As root, change the owner of the disk. Or change the permissions.

For “/home” it is usual to have owner root. But each user has their own directory within that file system, and they own their own directory.

You could, perhaps, do (as the root user)

cd /Programming
chown techwiz03 .

Change that “techwiz03” to your login user. Then you should be able to write to that disk.

If you want several people to be able to write to it, then try:

cd /Programming
chmod og+w .

That will give everybody write permission.

For the vfat file systems, ownership is faked by mount attributes. It is best to not change that for “/boot/efi” because it is a critical file system that affects booting. But for your other vfat volume you could try changing the options column from “defaults” to “uid=1000” so that the files are owned by user 1000. The man pages for mount(8) list other options for “vfat”.

Partially successful
chown worked for /Programing and /home1 which were /dev/sda8 and /dev/sda6 respectively

changed fstab to say uid=1000 instead of default for /dev/sda 4 (NTFS) and upon reboot was dropped to CLI in root mode to fix the problem.

replace fstab with original and rebooted worked.

will examine man mount to see if it has clues to how to manage ntfs drive

According to information provided so far /dev/sda4 is not NTFS, it is VFAT.

and upon reboot was dropped to CLI in root mode to fix the problem.

Does user with UID 1000 exist?

According yast user & group security I am user 1000 member of user, virtualboxuser, and root

According to /etc/fstab /dev/sda4 is vfat, According Yast it is vfat,ntfs and according to windows in virtualbox it is ntfs.

Man mount says vfat refers to vfat and ntfs

Before i upgraded 15.0 to 15.1 /dev/sda4 showed as vfat in ftstab and as ntfs in Yast partitioner now yast shows vfat,ntfs and if try to edit that partition under filesystem type there is type vfat but no type ntfs.

Look at the permissions of the mount points. I.e.

ls -ld ~/Programming 


one more try
Signed in as root , tried to chown to root:users on /dev/sda4 mounted on /home/rick/e-drive and after a log pause it says ownership can not be changed.

So anyone can see the files but can’t open any save any copy any unless they are root.

says group and others can read & execute but not write owner root can do all.

linux-bdgk:~ # ls -ld /home/rick/e-drive
drwxr-xr-x 28 root root 32768 Dec 31  1969 /home/rick/e-drive
linux-bdgk:~ # 
linux-bdgk:~ # chown root:users /home/rick/e-drive
chown: changing ownership of '/home/rick/e-drive': Operation not permitted
linux-bdgk:~ # 

in my fstab it says

UUID=ABC9-795A                             /home/rick/e-drive  vfat  defaults        0  0

but reading community post on mounting ntfd it says

UUID=01D4C2D9B9214530 	                   /ntfs/C  		       ntfs-3g 	defaults 

And i had changed in the top one defaults to uid=1000 which caused an boot error. will change of vfat to ntfs-3g correct it?

Your UUID of “ABC9-795A” is similar to what I see for FAT drives (or “vfat”). The UUID for NTFS is usually longer, as in the example that you show. So I think it likely that your drive is FAT, not NTFS.

that drive was original drive d: in windows
windows ‘c:’ crashed some time after making drive d: ntfs
Susequently I kept d: unchanged Put linux onto space occupied by old c: and loaded windows as virtualbox in linux with the old d: as shared drive.

after many upgrades to linux I still had read/write access to shared drive now called e-drive under home/rick/e-drive but after re-install of 15.1 and the changes from my other posts now only root can access and make changes.

For both FAT and NTFS, you can use “uid=nnnn” as a mount option to set the owner.

Ok will retyr /etc/fstab mod again and hopefully it won’t drop to cli root with a problem as before.

Problem solved.
retried change to /etc/fstab changing defaults to uid=1000 taking care not to add or remove any spaces and it worked.

I now have access the way I used to have.

thanks guys.