More VLC woes

Since I have two installs (one desktop and one laptop) that are essentially identical, it is confounding to me that I can open a webcam on one computer and not the other. Trying to look at file differences between the two, I got a more confusing situation. The working version (laptop) opens a stream from the webcam and briefly the screen shows “v4l2://” On the desktop, trying the same webcam gives me the error that I cannot open “MRL v4l2://” BTW, I have one usb webcam that I move back and forth between these computers.

Looking for the files or location in question, I see the desktop has many, many more files in the v4l2 directory, including a half dozen rpm files. I cannot delete these. Yast says it has deleted them but they remain. Dolphin will not give me the option to delete when I right-click on them. I copy the file names (copy, not type) to try zypper rm. Zypper says no such file, even though I’m looking at it. All the files/folders related to v4l2 on both machines are owned by root. I was thinking I could delete the v4l2 folder and it would recreate itself properly somehow, even if I had to download some rpm’s again. Still that scares me as a sledgehammer approach that might not even work.

So, even if I can’t get the webcam working, I’d like to know why these rpm files are permanent.

I can only offer general advice here, but it seems to me that you were having these issues weeks ago…

With respect to the VLC error, I expect it reported something like “VLC is unable to open the MRL ‘file:///dev/video0’. Check the log for details”. Did you then check the log?

As per the advice in this thread start vlc in verbose mode (for debugging)

vlc --verbose 2

VLC log…

cat ~/vlclog.txt

That might help yield further useful information, otherwise we can only speculate. :wink:

More info:

Thank you deano_ferrari for trying to help.

You’re right. I gave up for awhile after the previous posts for help. That’s why I tried a new thread.

The vlc --verbose 2 command

gives me a great deal of output. I can post it but it is dozens and dozens of lines. I have to confess my ignorance. I didn’t know where to look for the log referred to in the error message. With your advice, I ran

cat ~/vlclog.txt

but the result was

/vlclog.txt: No such file or directory

I did this, obviously, on the problem computer. I’m going to go boot up the laptop and run these again for comparison purposes.

Booted up the laptop and opened the webcam. It worked as expected. I ran the two commands and looked for differences from the desktop. There still was no vlclog.txt but scrolling back through the verbose output I found errors in the webcam output.

**00007f9ec8001120**] v4l2 demux error: **not a video capture device**
**00007f9ec8001120**] v4l2 demux debug: opening device '/dev/radio0'
**00007f9ec8001120**] v4l2 demux error: **cannot open device '/dev/radio0': No su**
ch file or directory

This error is repeated but refers to “no streaming device.” These errors do not appear on the laptop where the webcam is working properly. At first, I thought a solution would be to buy a new webcam. But, why would the results be different? Also, the webcam has a built-in mic which works on the laptop. I presume that mic is the source of the error message about radio.

What does the following report?

v4l2-ctl --list-devices

I get this:

v4l2-ctl --list-devices
MyPhone Camera (platform:v4l2loopback-000):

Webcam (platform:v4l2loopback-001):

USB2.0 PC CAMERA (usb-0000:00:1d.0-1.8):

That is the desktop where it fails. On the laptop, where it works, I get only the part starting with USB2.0. Before I found this webcam in the garage, I tried using an old cellphone as a cam with a couple of different apps and files from the repo. I wonder if there is a conflict from this lingering software. I also tried selecting video0 through video3 specifically instead of letting vlc select what it saw as default. There was no option to select media0. The result was always the same: failure.

What is reported by the following?

ls -l /dev/video*
crw-rw----+ 1 root video 81, 0 Jan 27 15:57 **/dev/video0**
crw-rw----+ 1 root video 81, 1 Jan 27 15:57 **/dev/video1**