More Plasma-problems in KDE4.2.2

With OS11.1 and KDE4.2 Plasma started to eat memory. Then i upgrade to KDE4.2.1 and the memory-problems seems gone.

Now i upgraded to KDE4.2.2 and now Plasma start to eat CPU. Its stuck on aprox 49% CPU.
I run two Plasmaoids; Clock and Calender

To bad i can’t see what Plasmaoids that hog CPU!

There are logical ways to address this:

Try removing all plasmoids you added, just use a basic desktop.


Try a new .kde4 folder (keep the old one, just rename it .kde4_old) see if you still have the problem. If not then the problem is in your settings and not necessarily a fault in plasma.

I’ve seen a lot of people having trouble with the calender plasmoid, so I’d try to remove that one first.

I’m glad I’m not alone on this one. I have the same thing happening to me. Plasma is stuck at around 50% cpu usage right after I upgraded to 4.2.2. :frowning:

I took all plasmoids out except the calendar. I will try that and report back.

Thank you.

Run ‘kysyguard’ and look under ‘processes’ tab (or you can run ‘gnome-system-monitor’ if you have GNOME installed also).

Alternatively type ‘top’ into a console to get a list of processes with CPU/Memory usage.

For me the process that is constantly at around 50% is Plasma. That’s it just plasma, so I don’t know if the widgets are encompassed in that particular process.

The calendar did it for me. I removed it and the cpu immediately went down to its normal mode. :slight_smile:

The question now would be why the calendar? Before upgrading to 4.2.2 everything was fine. Oh well, I can live without the calendar for now. Hopefully it would get fixed.

Thank you for the suggestion.

I’m repeating a reply from another thread. I had this problem and removing the calendar widget solved it. But, I have a low spec machine running 11.2 and kde 4.2. That machine has no problem with plasma and the calendar widget.

I started having the problem about the time I noticed that the nvidia splash screen on this pc no longer said “beta.” It must have updated my legacy driver. It could be that, since the other pc has on-board intel graphics.