more NVIDIA update X crash fun

After fixing (or at least working 'round) the problem described in this thread:

KDM doesn’t start after NVIDIA update startx does - openSUSE Forums

I have been fool enough to update my NVIDIA driver again (I’ve done it many times before 11.1 without problems) and have run into a similar problem.

I am using openSUSE 11.1 x86_64 with

This time after kdm launches, I just get a non-blinking cursor in the top-left corner of the screen. I cannot switch terminals (ctrl-alt-FX) or apparently do anything.

Consequently I can’t try installing the old NVIDIA driver. However I have another installation on this machine which makes it easy enough to edit any necessary files and try rebooting.

Autologin is not turned on (due to problems described in other thread). I’ve tried switching the xorg.conf file (in desperation more than anything) without any effect.

I know this is very little information to work with let me know what other information I can post.

Even if you don’t know what the problem might be, if you can tell me how I an boot to the straight to the terminal (not starting X) so I can try reinstalling the old NVIDIA driver, that would be very useful.

Thanks

FIXED*

I edited /etc/inittab to boot to runlevel 2:


# The default runlevel is defined here
id:2:initdefault:

Then reinstalled the old NVIDIA driver using the installer NVIDIA shell script installer (I keep old ones in case of emergencies like this).

Then switched to runlevel 5:


su -c 'init 3'

(return to get command prompt back)

su -c 'init 4'

(return to get command prompt back)

su -c 'init 5'

(return to get command prompt back)


N.B. I don’t know whether it is really necessary to do 3,4,5 like that, maybe just 3 and 5 or just 5.

When it booted properly, I edited inittab again to default boot to runlevel 5 and all seems to be ok.

All I need to do now is to uninstall the old NVIDIA driver using YAST then reinstall again with the script to make sure the package database doesn’t think I have the new driver installed.

I may even try reinstalling the new driver using the shell script/binary thing instead of yast and see is that works better.

AND TO FIND OUT WHAT BAD STUFF HAPPENED WHEN I DID LOOK HERE

Hi,

I do not know if this helps but I had a strange behaviour with my NVIDIA 9600 GS and the X Server.

My Asus m50vm installed the nvidia drivers with no problem.
In my case the strange behaviour was that after shutting down the PC it never started the kdm and X server on the first boot!
After reboot with <crtl-alt-del> things where ok.

When I looked at the logs the only warnings where the ones mentioned on the forum about not having the path /usr/share/fonts/TTF and OTF.
There where no errors there.
I created the folders myself and placed there the fonts.
The warnings where all gone.
But the problem remained the first boot never started the Xserver.

Everything was ok in the Xorg log files.
Everything was ok in the kdm logs.
There was no problem whatsoever in the dmesg also!

So I started to reinstall the new Nvida stable driver 180.22 … it was a mess!

I may have done something stupid, so I re-installed the older 177 driver, first with the Nvidia installer, then with yast.

Well … same behaviour … the first boot always failed to start the X Server.

I also noticed that the X Server was indeed not the problem.
On the command line I logged in a terminal and made startx … everythign worked. It started a root X session with no problem.
On reboot with <crt-alt-del> thing where fine!
It rebooted and it showed the graphic login panel.

So I started Yast and sax2 and … I noticed that after installing the nvidia drivers and setting up the screen resolution with the nvidia tool the sax2 panel shows two different resolutions for the display!

In the sax display the top of the sax2 interface shows the correct screen resolution, in my case: 1440X900@70Hz, set wih the nvidia tool.

The bottom part of that interface, the panel that says “properties” displays a different display resolution, it mentioned 1024X768 … 16.7million colors …

(in previous version this was the resolution set for a safe reboot I think … )
So I say to myself … this must be it … !

I change that value to the correct 1440X900 screen (tft) resolution and Bang!
Now it boots first time with no problem!

Regards,
Pedro

My apologies …

This morning I booted again the machine and the problem remains.
First boot always fails to start X server!
I always must reboot in order to have graphics running.

Does any one have the same problem ? And, better yet, a solution?

Regards,
Pedro

Hi,

After all the mess I decided today during the morning to install the new NVIDIA drivers.
Version 180.22

After a lot of problems and googling about the install process I found myself with the driver error message that says:

API mismatch: the client has the version 180.22, but
this kernel module has the version 177.82. Please
make sure that this kernel module and all NVIDIA driver
components have the same version.

After several install/uninstall attempts I found a simple recipe to make things work again:

openSuSe 11.1 & NVIDIA 180.22 Driver - Page 3 - nV News Forums

I simply uninstalled everything (both from the shell Nvidia_installers —uninstall, both verisons, 177.82 and 180.22).

./NVIDIA_INSTAller --uninstall
  • Started a GUI session from prompt making
sax2 -m 0=vesa

and then I installed the nvidia drivers 177.82 from the NVIDA repos.

  • After that I uninstalled them also from yast Software management(sounds dumb but it works … )
    and went to the shell prompt I then made the system go to runlevel 3 .
init 3

(No need to remove the NVIDIA repos from the repositories ! I did like that and it did not install the new drivers.)

  • Then I runned the NVIDIA installer for 180.22

And that’s it … after the boot I made sure to run again sax2 from Yast and set the correct resolutions on screen.

Hope it helps more folks …

Regards,
Pedro

Hello,

I had a similar problem with a laptop dell lattitude d830 with nvidia quadro 135M. I installed opensuse 11.1/64bits. With this nvidia card one has to download NVIDIA-Linux-x86_64-180.22-pkg2.run and recompile the kernel sources. Launching ./NVIDIA-Linux-x86_64-180.22-pkg2.run (after chmod +x) recompile the kernel but sometimes there are older nvidia graphic card kernels that are the origin of the problem. Go to Yast2, search for nvidia, delete the nvidia installed kernels and launch again ./NVIDIA-Linux-x86_64-180.22-pkg2.run. Hopefully it will work now

If things are still failing, try the following:

modinfo -n nvidia

This will tell you which nvidia.ko is being loaded.

After removing the nvidia packages, it could be possible that an ‘nvidia.ko’ file is still present in /lib/modules/uname -r/updates/

You can also find that out by running:

cd /lib/modules/`uname -r`/
find . -name nvidia.ko

Removing that nvidia.ko file in the ‘updates’ folder solved the issue for me. :slight_smile:

This module was being loaded instead of the file which the installer puts in ‘/lib/modules/uname -r/kernel/drivers/video/’