More "No protocol specified" Woes!

I’m not altogether sure that this is the right place for this but it follows on from my recent post - **Failure of “Konsole” thru’ ‘No protocol specified’ **- through which I was ably guided a the Global Moderator, nrickert, & which turned up some anomalies in Tumbleweed. Here’s another:

localhost:~ # xmodmap -e “remove lock = Caps_Lock”
No protocol specified

I then tried a formula used by nrickert & copied successfully by me in the previous post:

localhost:~ # ( xmodmap -e “remove lock = Caps_Lock” & )
No protocol specified

but that didn’t work either, and nor did my last (rather forlorn) hope:

localhost:~ # ( xmodmap -e “remove lock = Caps_Lock” )
No protocol specified

which didn’t work either (not that I expected it to).

I also tried the same with:

Bash - 4.4.23 : /usr/bin/setxkbmap -option ‘’ -option ‘ctrl:nocaps’
No protocol specified

I tried all these as variations as both Root and User with the same result. The ‘Nps’ problem seems to be a Tumbleweed bug. What can I say but “Grrr”.

Into the command line of Leap15, I entered ‘xmodmap -e “remove lock = Caps_Lock”’ which it accepted without demur but which made no difference to the “Caps Lock” control, but "/usr/bin/setxkbmap -option ‘’ -option ‘ctrl:nocaps’ " worked perfectly & disabled the key. I have now put this into the “.profile” and all is well.

OK! I have become aware that I can go:

System Settings=>Input Devices=>Keyboard Hardware and Layout=>Keyboard=>Advanced=>Caps Lock behaviour=>Caps Lock is disabled. (and this is what I eventually did with Tumbleweed)

But, to be perfectly honest, putting: xmodmap -e “remove lock = Caps_Lock” or even the slightly more complicated: /usr/bin/setxkbmap -option ‘’ -option ‘ctrl:nocaps’ into a file is no more difficult - especially as these files - .bash_aliases, bash_profile & .bashrc - have seen service with me, with occasional modification, for the last twenty years or so!

A bug - “grr” indeed!


OK there seems to be some progress here!

The only way I could launch “gparted” (and keep it running) was by opening a “root” terminal, typing in:

localhost:~ # ( gparted & )
localhost:~ # Too few arguments.
No protocol specified
libparted : 3.2
localhost:~ #


gparted was then launched but the terminal was still in its thrall. The cancellation ^C left the GUI running outside the while the terminal continued to run. This was possible because of the final & on the command line.

Pressing the “gparted” button brought up “Authentication is required to run the GParted Partition Editor”; fill in the “Password for root”, which I did, and Zilch; likewise opening “krunner” with alt-f2 entering “gparted” into it merely led to “authentication----etc, etc.” and another fail.

I eventually hit on


which I changed from

/usr/bin/gparted %f 


xdg-su -u root -c "/usr/bin/gparted %f "

Press the button now, and it appears to work fine!

Hope this is some help to someone!


First question that arises in cases like yours: how did you upgrade? If not through ‘zypper dup’ then run that first and check whether the issues persist after a reboot.

Knurpht - I ALWAYS upgrade Tumbleweed with “zypper dup”. Since I installed Tumbleweed on 06Aug18 there have been 10 upgrades (08/06, 11, 14, 18, 23, 29, 30(x2) , 09/01, 07). I have a complete set of records for all of these if you would like to see them.

Gparted is not include as part of Tumbleweed and was installed on 31Aug2018