More "blank screen at/after bootup" problems

This is my first forum post, so please bare with me…

So, I have a HP ProLiant DL120 rack server that I am trying to Susefy. It very recently ran Ubuntu Server 10.04 with no problems, but for various reasons I want OpenSUSE on it.

It has a Matrox G200-chip (or so I believe) and should hence be using the mga driver (the ubuntu installation did, and that was all fine and well).

I have a similar problem as many others - that the install went fine, but upon reboot, the screen turns black (blank?) after the splash screen.

I have tried nomodeset and failsafe with no luck. What is more annoying is that I cannot get into runlevel 3 (or 2 or 1) either - same thing happens. I have also tried “video=normal” without luck.
I do get a lot of console blarb while booting failsafe or with splash=0 set, and the last thing I see is something along the lines of “Starting virtual console” and “found a console on /dev/tty1” just before the screen goes black.

Is there anything I could try at grub menu in addition to the ones already mentioned?


Reading your post, I can’t tell if you attempted a DVD install, or if you are booting to a liveCd, or what … I assume your server does NOT boot to a liveCD but thats a speculative assumption on my part. Was this in your post and I missed it ?

When I type (on openSUSE) :

man mga 

I note:

       The mga driver supports PCI and AGP video cards based on the following Matrox  chips.   They
       are  listed  in approximate chronological order of production (with the most recent chipsets
       listed last), so consult this list when you are unsure whether your card is meant when  ref-
       erences are made to `G200 and later' chips, for example.
       G200   Millennium G200 and Mystique G200

so it should be supported.

Failsafe (or safesettings) not working is not so good. You try removing the specific vga entry at the grub menu when selecting fail safe and then boot, but thats a wild guess and not a serious suggestion. Selecting fail safe should force the FBDEV driver to boot, and its not common that driver fails.

You could try going into the /etc/X11/xorg.conf.d/50-device.conf file, and replacing the entry for ‘radeon’ with ‘mga’ and uncomment that line, reboot and test. A good text editor for using in a full screen terminal mode is midnight commander (called ‘mc’) and if that is not installed, it can be installed with:

zypper in mc

with pc connected to interent.
and then run by typing ‘mc’ . It can be run as a regular user and as root.

Did you check the md5sum of the downloaded iso file against the md5sum posted on the openSUSE web site and confirm they are the same ? Did you burn the iso file of the CD (or DVD) to a high quality +R or -R at the slowest speed your burner allows (and NOT to an RW). Also NOT to a bargain basement CD/DVD ? Did you then run the media check and confirm the CD/DVD good ?

You could also try posting to a web site such as SUSE Paste the content of the /var/log/Xorg.0.log file and then share the URL/address where that is located here, so that one of our forum guru’s in this area can check out the file and read the error messages.

Thats bad - and that makes me think this is a bad CD or DVD .

Thank you for your swift reply!

Sorry, it wasn’t in my post, I suppose I should have been much more verbous: I installed OpenSUSE 11.4 from the 4.7 Gb DVD image burnt on a TDK DVD+R.
The system installs without complaints (which I interpret as indication of a working DVD) - I have not tested a live cd (yet).
I chose to install the XFCE desktop when given the choice during installation.

I am not so sure the failsafe (or the different runlevels) does not work per se - I get the feeling that the system boots and is running, but that the graphics are failing - even console graphics. Might it be the FBDEV driver that doesn’t like my system, so that it starts but cannot provide me with any graphics and hence remains black? It would seem FBDEV loads even when I try to boot to runlevel 3. Should it do that? Can I in such case disable it in the Grub Startup menu?
Since I do get some text output while booting e.g. failsafe, it seems that before loading the FBDEV everyting is fine…

Ah, that might be of some help!
My problem is I cannot access the system at all, since the screen is blank also in console mode (ctrl+alt+F<1,2,3,4,5,6> makes no difference).
I more and more get a feeling that the FBDEV might be the culprit. Could it be that it also prevents “normal” graphics from loading?

As mentioned above, I believe the DVD is good, although I haven’t run media check to confirm the DVD viability. I did however run md5 on the iso, and it checked out ok.

I will try that if I can get so far as to access the system at all :slight_smile:

Thank you again for all your help!! I will continue to battle my machine, and will post back here if I get anywhere.


You need to run media check. You can have a good iso and a bad burn.

I ran a media check on the DVD an all was ok.
I just burned a OpenSUSE Live Gnome cd just to test if that would show the same problems.
Booting the Live cd showed other (but likely related) errors:

gdm will not start and I get error messages saying:
** (gdm: 4210) WARNING **: Failed to acquire org.gnome.DisplayName

** (gdm: 4210) WARNING **: Could not acquire name; bailing out

Then gdm fails three times and gives up.

At least I get a prompt, and after logging in as root I check /var/log/Xorg.0.log that says by the end:

65.241] (WW) MGA(0): Shrinking virtual size estimate from 1280x1024 to 1024x768

65.246] 0: /usr/bin/Xorg (xorg_backtrace+0x37) [0x80ee5f7]
65.247] 1: /usr/bin/Xorg (0x8048000+0x5cbea) [0x80a4bea]
65.247] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xffffe410]
65.247] 3: /lib/ (0xb73b6000+0x1663bf) [0xb751c3bf]
65.247] 4: /usr/lib/xorg/modules/drivers/ (MGAValidateMode+0x30) [0xb718a7a2]
65.247] 5: /usr/lib/xorg/modules/drivers/ (0xb71ef000+0x1142d) [0xb720042d]
65.247] Segmentation fault at address 0xddc8528b
Fatal server error:
65.247] Caught signal 11 (Segmentation fault). Server aborting
Please consult the The X.Org Foundation support
at X.Org Wiki - Home
for help.
65.247] Please also check the log file at “/var/log/Xorg.0.log” for additional information.

Segfault?? Why?? What have I done wrong??
Any ideas?

With the liveCD, you can choose a text boot as an option. Does that work? You may also need to type ‘nomodeset’ with that text mode selection.

The liveCD user name is “linux” and the password is the ‘enter’ key. The root user has the same password on the liveCD.

If linux is already installed, and if you are booting to an installed system, at the grub menu you can press ‘3’ such that a ‘3’ (no quotes) appears in the options line, and that will boot your PC to run level 3 if all is nominal. Its possible you need to type ‘nomodeset 3’ in order to get a login prompt. Then login with your username.

Can you get a text mode login with either approach ?

Just a quick partial reply before I fall asleep.
I have not tested booting text mode with the live cd, but after gdm fails, I do get a text login prompt. Login in as root gave me the opportunity to investigate errors reported in Xorg.0.log as described above.

The machine has an OpenSUSE system installed from the 4.7 Gb DVD image.
That installation gives me no prompt (or if it does, I can’t see it since the screen remains black) even with “nomodeset” and “3” as Grub menu options.
I have hence not been able the check corresponding x-errors on the installed system.

I will make sure all is repeatable when I return to work in some nine hours.

Ok, further testing:
I reinstalled OpenSUSE from the 4.7 Gb DVD, but choosing text only, instead of XFCE, as ‘desktop option’.
Everything went fine, and the installed system boots nicely into runlevel 3.
I then installed xfce and tightvnc, and can now vnc into the machine and use a remote xfce desktop.
When running

sudo /etc/init.d/gdm start

locally, the screen goes black and the machine becomes unresponsive, needing a forced hard reset to reboot.
Upon reboot, it nicely boots to runlevel 3 again, and I can again use vnc to access a virtual desktop.

My conclusion is that the mga driver supplied with OpenSUSE has some form of bug that severely cripples the system (indeed freezing it completely).
I will not have time to investigate more thoroughly right now, but if some logs or some simple tests would help anyone, I will gladly provide those upon request.

Thanks again for all help.

Well unfortunately the big 3 video suppliers are NVIDIA, ATI and Intel. So the smaller less seen cards may not get the needed testing. I’d report this on Bugzilla.

I’m currently on vacation in Berlin and not able to provide much in line of support. But I suspect the files that would be useful to copy and paste on SUSE Paste are:

  • /var/log/Xorg.0.log
  • /var/log/boot.msg

and post here the URL/web address provided from the susepaste site.

I will do that - I guess a solution should be possible since it seems to work under Ubuntu.

Here are the susepastes

Xorg.o.log: SUSE Paste
boot.msg: SUSE Paste

Bug 684043 Submitted to bugzilla.

Thanks. I was reading the bug report #684043 but it does not look hopeful. Ubuntu are not known for passing their fixes upstream in any sort of timely manner, and I think their X setup is sufficiently different from openSUSE that it may be difficult to easily see what they are doing. I’m not optimistic about this progressing further, but I guess we will see.

Thanks for raising the bug report, as its the best we as users can do.