Moore language problems.


Well I’m not sure that I have the most common set up on my DE’s(KDE Leap42.1). I’m using US English as system language and Swedish as regional settings. Had been working a-ok sins(OpenSUSE 12.x ? ). It was working fine all the time up to a month ago or so on Leap42.1 as well.

I cant open any files with the Swedish characters Å Ä Ö (å ä ö). Not locally (on local disc), not on 13.1/42.1 openSUSE servers. Not on Win 2008/2012 servers by smb.

Attach a picture of how it look when trying to open Libreoffice dokuments ie.

This I have survived to copy the files to my local disk and take away/translate the local characters. For me another thing more annoying function was that my Leap42.1 Laptop with the owncloud client started to delete all local characters in filenames(in both ends) when synching against my home servers. Using US Eng and have regional settings to the same takes care of the problem for me.

Anyone else notice this? Any German that having a similar set up (US Eng and German regional settings ie) also using the character Ö (witch I Have the most problems with)?


“Some time a month ago”. That will probably not help in you reminding what you did just before you experienced the problem. Why waiting a month before seeking help?

It is my opinion that the language setting in the environment has nothing to do with the file names. File names on proper Linux file systems are in UTF-8 encoded Unicode since ages. And those file names do not change when the language connected environment variables of one process are different from those in another process. Look at this:

henk@boven:~/test/sw> echo $LANG
henk@boven:~/test/sw> touch Å
henk@boven:~/test/sw> l
totaal 8
drwxr-xr-x  2 henk wij 4096 29 dec 19:16 ./
drwxr-xr-x 15 henk wij 4096 29 dec 19:14 ../
-rw-r--r--  1 henk wij    0 29 dec 19:16 Å
-rw-r--r--  1 henk wij    0 29 dec 19:15 aap
-rw-r--r--  1 henk wij    0 29 dec 19:15 नमस्ते

As you see my language is Netherlands (Dutch to most people here). I can create a file named Å without any problem. And as you can see from the listing, there is even a more “excotic” file name in Devanagri there.

The above to avoid that you are trying to solve the problem based on the wrong facts.

I have to admit though that I do not have an explanation for what you see. It looks a bit as if the files are on a non-Linux file system put there by an OS that does not use UTF-8 encoded Unicode.

Hmm… Thanks for the reply.

About a month I can specify, - I invested in SDD’s for DE’s the date was black friday on my main DE and and for my laptop 20151204 (can attach the receipt). They where both fresh installs. No, hokus-pokus Xn-software on non of them them.

Sorry if I didn’t ask for Dutch opinions. Yes we have some special characters in common. And yes I can manage some Africans as well.

I posted*-and-LANG-are-correct

Something is not right with Leap42.1 and my DE. The question is what did I do wrong? Or did I. And for what I have learn there is a problem with Leap42.1. When using US lang all over everything is working.

I know that I’m a not casual/usual user. I manage anyway.


Not the Å I used above. The idea is to show you that files can have all UTF-8 encoded Unicode characters (except /) in their names and that creating and listing them is independent from the value of the LANG process environment variable.

I’m facing similar problems with my installation. I have tested different DE and it works properly with Gnome and Mate, but not with KDE. Libreoffice is particularly causing problems and had earlier problems as well with Gwenview, but installed an other version of it which worked well. I am using Finnish locales and has also tried Swedish without success. System language is English.

Apparently you are not living in my word. I’m quite tired to read of the suggestions of mail-list. If that is the question of openSUSE should grow/survive so no thank you. I will found a way.


Sorry, I realy do not understand anything of this.

I’m not suprised.

Noticed soapbox and a

On the other hand I notice (in Swedish). Jupp close to politics, Why us? Why not your own… Of course you can read Swedish. About the same about Leap42.1 and language.


This ownClowd thread How to fix local/ Problems with special characters might be helpful to you?

  	  			[How to fix locale/ Problems with special characters](]( **[RandolphCarter](** » Fri Feb 01, 2013 10:15 pm 
  		  			**Note:** The  following applies if your ownCloud server is running on Linux; it is  not valid for an ownCloud server running under Windows; on Windows there  is another problems with special characters which unfortunately can't  be solved at the moment because it's a php problem (see [this discussion](

If special characters in filenames you have uploaded to ownCloud (be it via the client or via the web interface) don’t show up properly (e.g. that a special character at the beginning just disappears in the web interface), try this: