MonoDevelop - Compiler not found: g++


Ok, i just installed MonoDevelop and i was trying to play whit it (i really don’t remember much about programing anymore, but i would like to remember something, anyway) everytime i try to compile anything i keep getting this error:

Error: Compiler not found: g++ (test)

can anyone help me solving this? (i’m new at Linux so, please, be gentle LOL)

you need to install the g++ compiler

Ok, and how do i do such thing?

I’ve been in yast and i can’t find anything like that :shame:

YaST2 ==> Software Management ==> Search [gcc]

Installed gcc (gnu C Compiler) but the error is still there :frowning:

By the way, since i installed monodeveolp via 1-click install shouldn’t this kind of things be working “out of the box”?

any other idea :shame:

I don’t have experience with mono, but here are suggestions.

Check the compiler from terminal:

g++ hello.C

Remove mono. Remove its remnant configuration files, which may be in .kde4/ or in .mono/

Install mono.

g++ is part of the GNU C Compiler, just out of interest what does

echo $PATH


locate g++

return. I suspect you are missing something in your path.

/home/speccy/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/opt/kde3/bin:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:. locate g++

this is what i get when i echo $PATH locate g++ :s

Hello? Anyone?


I’m not sure which version of SUSE you have but if you go into the Install Software applet, then look on the Installed tab. Within the Programming section to the right, you should see a gcc<version>-c++ GNU compiler or something to that effect. I have the gcc43-c++ compiler.

If it’s not installed, then you need to install it. Go to the Available tab and look for the same. The installation will put it in your PATH.


I tried installing gcc44-c++, but it still showed the same error, then i tried the gcc-c++ (without version number) and that apparently solved the issue :slight_smile:

I don’t know, however, if this two (gcc-c++ and gcc44-c++) are supposed to work together or if they can conflict with each other.

Any idea if i should let them both or if i should remove one of them?

thanks a lot for your help :smiley:

Look at yast2 → Software Management → gcc-c++ → Dependencies: gcc-c++ requires gcc44-c++

I see…

Thanks for teaching me that :smiley: