Mono for openSuse 13.1 ......

First of i am sorry if this is a wrong place to put this question?
I am very new to openSuse, i am coming from windows and i am a .net developer , i searched a lot how to get mono working on my openSuse 13.1 os, but either i do not understand what to search or i am searching like a windows guys because of course things are very different in windows… so i need help about the following things and i need tutorials or guides to do the following…

  1. Where will i get latest mono and monodevelop rpm packages for openSuse 13.1(I want to develop mvc 3,4 websites using mono)?
  2. How to compile latest mono from source what prerequisites will i need?
  3. Can i use rpm packages targeting other versions of openSuse (as the mono package from mono official site targes openSuse 11 or something) ?
  4. And in future where should i look for this kind of information?

related things that i know

  1. I can use git.
  2. I can compile sources.
  3. I know that websites can be served using mono+mod-mono+mysql+apache.
  4. I know the basics of using terminal.

When I approach what you ask for the first time, I generally search the packages first, either in YAST or I just type into a console

zypper se mono

The result should be all the packages which contain the string “mono”
For starters you should see the base packages and then some packages that are obviously optional.
Install what you want.
Then, as caf4926 recommends you might do a search at to see if anything has been contributed outside the main repos.

I happened to glance through the mono packages per chance a couple days ago and was surprised to see special support for I don’t know if anything has changed, but my understanding is that there are still a few significant parts of Microsoft’s ASP.NET that are proprietary so would be difficult or impossible to port existing many ASP.NET websites like SharePoint or DNN, but if you’re building new should not be an issue.

My Q would be why you really feel the need for “latest”
In general treading too far out on the edge when you haven’t tried current stable is dangerous, but if you want to go that direction,

  • Search for, inspect packages in the Factory repo
  • Add the mono repo (the following should work on 13.1)
zypper ar  Mono:_lang:_Factory

Just another word of caution, there can be more heartache than reward going out too far on the edge. If you do, be sure to document the problems you run into and submit bugs at


I have done what you told me and took your cautions too but as i am just experimenting not doing production work i think their is no harm.thanks for your help i got mono 3.2.8 and monodevelop 4.2.3 from factory repos.And as of yet i have experienced only one problem the xsp4 was broken or was missing some functionality. It was issuing a not implemented exception…,and when i google it it was reported as bug to mono-project, but i could not found any solution or fix, then i compiled xsp 3.0 from git and replace the factory repos version of xsp with my own compiled one and the problem was gone . I think the xsp included in the factory repos of mono 3.2.8 and monodevelop 4.2.3 is an older version of xsp or it might be broken.

Unfortunately, what you’re seeing might just be fairly common. Awhile back when I had a fairly strong interest in mono, I found that monodevelop had significant bugs which were over a year old and didn’t have a working debugger. Coming from a background using Visual Studio, I couldn’t imagine an IDE without a debugger… It’s perhaps one of the top 3 essential and indispensable tools in an IDE. Those issues have been resolved now, but it still sticks in my mind how critical issues could remain unresolved for over 2 years, and especially when at least some of the issues were more integration rather than the function doesn’t exist (the advice was to run a debugger outside MonoDevelop).

Also, since Mono became semi-closed I’ve been less enthused using Mono. For certain things, I think it’s a really great technology without peer(eg Far better than Java or any of the scripted technologies) and I do recognize the need to be solvent when the authors lost Novell’s support (the sale), but the model they chose significantly throws cold water on anyone who is interested in using the technology.

For that reason I do recommend considering the very latest (maybe even bleeding edge) versions when you run into major issues.


When I started this project, I expected that Mono evolve faster than me and I could make the connection between my app and MVC 4 in mono.
Now it is possible.
I fully developed my application sour visual studio without using exotic libraries also, in theory, it should work under Mono.
I need help to get there.
At the moment, I try in a virtual machine OpenSuze13.1 but when I installed. Net development from YaST, I launched Develop mono and I had the same problem, namely 3.0.6 MonoDevelop. When I created my MVC solution “out of the box” 2 references were missing: System.Web.Helpers and System.Web.WebPages.
I Assembly not available for Mono / net. 4.0 (in Mono 3.0.6).
What can I do to make it work?
Thank you for your help,

I haven’t built or tried to port a VS project to MonoDevelop for many years, but back then if your ultimate objective was to port, you <did not> use the standard ASP.NET libraries in VS. You downloaded, installed and then built your VS project using Mono libraries.

Then, your port should be problem free.