Mono debugger doesn't connect to Monodevelop

Hi i’m using Open SUSE 13.2 and Monodevelop 5.7. When I try to run the Hello world example Monodevelop writes when starting a console project I get a “Could not connect to the debugger” error.

To reproduce this bug Open Monodvelop 5.7 from the OpenSUSE repositories and make a new C# console project and try to run it. The the error occurs.

TY

So I found a workaround. :slight_smile:

When a console project is created, by default is going to run on an external console. This should by disabled.
Go to the “Project” and click on the last option of the menu which should have the name of the solution. In may case it was “test Options” because my project was called “test”.

To the left there’s a section called “Run”. There go to general and deselect the “run in external console” option from Debug and Release. And it should work now.

BD

Found a bug report on this. https://bugzilla.xamarin.com/show_bug.cgi?id=12684

Monodevelop can’t use gnome-terminal with the mono-debugger.

Been a long time since I’ve looked at Monodevelop (My biggest gripe at the time was that there were no integrated tools like debuggers).

So, installed Monodevelop and created a “Hello World” and it built fine.

Did you install the mono debugger? The following command installs both monodevelop and its debugger

zypper in monodevelop mono-debugger

In fact, I’d recommend that you view all the available mono packages and install you might need or at least know that those packages exist. The following command lists all available packages

zypper se mono

From what I can find, there is no special mono repository with additional packages.

HTH,
TSU

I did

sudo zypper in patterns-openSUSE-devel_mono

And still get the error. I suspect is that Monodevelop is not configured for 64 bit because the debug options point to x86 debug. Don’t know for sure.

but the patterns might not install mono-debugger
why not do what tsu2 suggested and install the package mono-debugger
just execute sudo zypper in mono-debugger or start-up yast and install all the mono packages you can find (including the -devel ones as you are planning on building code with mono), why because a pattern might not have all the needed packages, a pattern is a suggestion that you may change to suit your needs.

There seams to be a special debugger for monodevelop it’s monodevelop-debugger-gdb
it’s not in the main repository it’s in the Mono:Factory repo
see here for more info
https://software.opensuse.org/package/monodevelop-debugger-gdb

Thbak you but it didn’t work. I have the debugger installed. If I set Monodevelop to build for any cpu then it works. The other problem seems that gnome-terminal doesn’t integrate with Monodevelop.

Do you have the option to run in another Desktop where the default terminal application might be different?
Which Desktop are you running now, my guess is either Gnome or XFCE? - If possible you might try something else.

Or, maybe someone might be able to describe how to configure a different terminal app… If it’s not possible to do from within MonoDevelop.

TSU

In windows it works with CMD.

I dont know if im late to tell this but, it worked when changing the Desktop environment
i logged out and before logging in again, i changed the desktop from Gnome to IceWM
console and everything went perfect