Monitor won't sleep


I have installed a new GPU and had some problem with the driver, so I installed the amdgpu. Things work fairly ok, and the screen powers down after 10 min as I have set in the power section of th system setting, but when it comes to the login screen, the monitor gets dark, but powers up again after a minute and stays in the login screen. My thesis is that the gpu driver does not allow the monitor to power down.

Has anybody som experince regarding this?

Dag R

When you say installed the driver, amdgpu is default in oss, or do you mean the proprietary amdgpu-pro? If so, was there an issue with the oss driver?

What desktop environment?

What is the gpu you installed?

/sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"

dagr@opensuse:~> /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
03:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:7340] (rev c5)
        Subsystem: Sapphire Technology Limited Device [1da2:e421]
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu

I installed the AMD Radeon RX 5500 XT (it was replaced with an old ATI Radeon card which used the radeon oss driver) and the screen did’t look good. The resolution was garbled up, and when I ran /sbin/lspci -nnk | egrep -A3 “VGA|Display|3D” i didn’ẗ show anything in the line for kernel driver and kernel modules. I checked if the amdgpu driver was installed, and it was. I then installed the amdgpu pro driver, and most things looked ok (some slight flickering in the tops of windows when working with several windows) but over all it seemed to function. The hardware acceleration in VLC seems also to be not well. Bit the most irritating was the monitor sleep problem.

The output of the code does not seem to indicate the amdgpu pro driver is in use for this card, or what? I use the KDE Plasma desktop and hdmi cabel. I found this article about the same issue

Dag R

Since your using the proprietary driver, the bug relates to the oss amdgpu driver… but likely similar :wink: Perhaps ask on the AMD forums?

Did you try switch from HDMI to Display Port to see if that was better?

That card is not supported with the oss amdgpu driver in Leap 15.1 it’s too new…

If I understand you right, the card is too new, or the driver is to new? Can I retreat to the oss radeon driver? I read the card was included in the amdgpu pro:

I also do not understand if I’m using the oss amdgpu or the amdgpu pro?

Dag R

The card is too new, there is no support for the card with for the radeon driver, the gpu is amdgpu driver only.

uname -r

/sbin/modinfo radeon | grep 7340

uname -r

/sbin/modinfo amdgpu | grep 7340
alias:          pci:v00001002d00007340sv*sd*bc*sc*i*

Your running the amdgpu-pro driver (which is also called amdgpu), that is why before you installed there was no kernel module in use.

There are two FOSS amdgpu drivers:

  1. kernel
  2. X

lspci only reports the kernel driver in use. The X driver can be found in several ways, among which grepping in Xorg.0.log, visually scanning Xorg.0.log, and the command inxi -G, which reports both kernel and X drivers.

# inxi -V | head -n1
inxi 3.0.37-00 (2019-11-19)
# inxi -GxxS
System:    Host: localhost Kernel: 4.12.14-lp151.28.36-default x86_64 bits: 64 compiler: gcc v: 7.4.1 Desktop: KDE 3 wm: kwin
           dm: N/A Distro: openSUSE Leap 15.1
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Kaveri [Radeon R7 Graphics] vendor: ASUSTeK **driver: amdgpu v: kernel**
           bus ID: 00:01.0 chip ID: 1002:130f
           Display: server: **X.Org 1.20.3 driver: amdgpu** resolution: 2560x1440~60Hz
           OpenGL: renderer: AMD KAVERI (DRM 3.27.0 4.12.14-lp151.28.36-default LLVM 7.0.1) v: 4.5 Mesa 18.3.2
           direct render: Yes

I’ve never had need of the amdgpu pro driver, so don’t know what inxi might show differently.

Here is the output on my machine:

dagr@opensuse:~> inxi -GxxS
System:Host: opensuse Kernel: 4.12.14-lp151.28.36-default x86_64 bits: 64 gcc: 7.4.1
           Desktop: KDE Plasma 5.12.8 (Qt 5.9.7) dm: sddm,sddm Distro: openSUSE Leap 15.1
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Device 7340 bus-ID: 03:00.0 chip-ID: 1002:7340
           Display Server: x11 (X.Org 1.20.3 ) drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa,radeon)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Radeon RX 5500 XT version: 4.5.13581 19.50 (compat-v: 4.6.13581) Direct Render: Yes

This is really depressing. A new card and not a proper driver. I have tried to unistall the amdgpu pro driver, and install a nvidia card, but it is but the “amdgpu-pro-uninstall” script does not work. I have installed the nvidia driver, but the machine will not boot into the graphic interface. I think the drivers are mixed up during boot. Could you point me in a direction to solve this? I want the nvidia card to work, and put the radeon card in antother machine.

Dag R

These Phoronix reviews seem to indicate that the Radeon RX 5500 XT requires Mesa-19.3 (available in Tumbleweed) and kernel-5.5 (which is still at rc7 and not in the openSUSE repositories).

It’s tough at the cutting edge.

If you can boot into a (text mode), you should be able to run “yast” and reinstall “kernel-default” from the update repository. That should provide the standard kernel modules.

Thanx for explaining about the Phoronix reviews. I was a little pusseled about why they wrote the driver would work for RX 5500, and you guys said it was not ready yet. Now i know. It means I can’t wait for the driver to be available. As I wrote in the last post, I want to use the nvidia card I have. Will I get the it to work if I reinstall kernel-default? The kernel-default is installed now, but you mean I should use upgrade (the choices are keep, remove, upgrade, upgrade anyhow)?

Dag R

Yes in YaST Software manager “upgrade” of an installed package forces a reinstallation. This should replace any kernel modules that have been modifie, create a new initrdand rewrite the boot loader configuration.

I did as you said, but somthing went wrong:

system failed to load kernel modules

I tried to install the nvidia driver in the console version of yast, but it didn’t work. I suppose this interface is to new for me. What can I do now. Is it possible to restore the machine to another day via snapper? I can see the system has made a snapshot of tuesday. That was before I started to mess with the gpus.

Dag R

That looks like output from the ancient inxi provided by openSUSE 15.1 OSS, which provides confused report of X drivers and DM in use and no report of kernel driver. Inxi is simply a script. Install the one from TW OSS, or better yet, remove the rpm, and get the latest from upstream.

This is really depressing. A new card and not a proper driver. I have tried to unistall the amdgpu pro driver, and install a nvidia card, but it is but the “amdgpu-pro-uninstall” script does not work. I have installed the nvidia driver, but the machine will not boot into the graphic interface. I think the drivers are mixed up during boot. Could you point me in a direction to solve this? I want the nvidia card to work, and put the radeon card in [/QUOTE]I have no experience with amdgpu-pro installation or removal. My only experience with proprietary NVidia drivers is their removal. All my AMD and NVidia GPUs run purely on FOSS. All I can suggest is to purge all the proprietary software according to its own removal instructions, then try the NVidia GPU again.

Ok. I got rid of the nvidia prop driver and the amdgpu pro driver, and I get into the graphical interface. I now use the Nvidia card. Good, but mouse and network connection is not working. If you could tell me how to get the two things to work, I will be a large step in the right direction. Then I can set the screen resolution and check if all is in order.

It is some modules which is not loading in the boot process. I expect the mouse and network are among them.

Dag R

Ideally, you should start new threads to deal with these issues. For the network issue (wired or wireless?), tell us more about the hardware details to begin with

/usr/sbin/hwinfo --netcard

I se your point. It is a little too much in this thread. I will tell you a little more before I make a new thread. I fixed the network and mouse. I choose a kernel with a lower version number in the boot sequence. Most things works with this kernel. Can I now delete the latest kernel in yast (Plasma) and then upgrade to the newest kernel?

Dag R

For AMD Radeon RX 5500 XT + AMDGPU-PRO: try it with updated X11 and standard 4.12 kernel.
You may use this repo:

For AMD Radeon RX 5500 XT + Mesa 3D: you need new kernel + new Mesa 3D.

  1. You may update kernel from stable repo (5.5 is available):
  2. You may update X11 + Mesa 3D using this repo:
    Mesa 3D 19.3.3 is available.

Also possible you wlii need updated linux-firmware.

IMHO rigt now AMDGPU-PRO driver is preferable.

Thanks for the information. I have got the nVidia card and proprietary driver to work, so i put the Radeon card into another machine. I feel I have exhausted the forum with all my questions, so I’m very glad the nvidia card works ok.

Dag R