Monitor wierd pattern after sleep/hibernate

Hi All,
I am currently running OpenSuse v12.3 and experiencing an issue with my monitor whenever I put the OS into either sleep/hibernate state. The sleep/hibernate do put the PC to sleep/hibernate but when it wakes up, the monitor has all wierd pattern where I can’t picture what the screen looks like. Is it a video setting that I need to configure or an updated video driver ?

This is what I have:

~> /sbin/lspci -nnk | grep VGA -A2
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF106 [GeForce GTS 450] [10de:0dc4] (rev a1)
Subsystem: eVga.com. Corp. Device [3842:1450]
Kernel driver in use: nouveau

Any help or suggestion is greatly appreciated.

Don’t know but you might try the NVIDIA propritary driver. It may help.

gogalthorp,
Thank you for the reply. I was holding off doing what you suggested, but I finally went to nvidia.com. Here’s the url I went to, Nvidia Installer HOWTO for openSUSE users and the steps I took from the Release note. Bare in mind, I change the repository directory to 12.3. My issue is now resolved.

  1. openSUSE 12.1-AMD64 It is recommended to use YaST for installation of the NVIDIA
    driver. There are several reasons for this. First, it’s
    simple. Second, and this is the most important one, you won’t need to
    recompile the nvidia kernel module after a kernel update.

Update your Kernel via YOU (YaST Online Update). Use

YaST -> Software -> Software Repositories -> Add

Protocol: HTTP
Server Name: : download.nvidia.com
Directory on Server: /opensuse/12.1

to add the NVIDIA http server as additional installation source.
Now use

YaST -> Software -> Software Management

to install the NVIDIA driver. The appropriate NVIDIA packages will be
autoselected, if your card is supported. These are either

a) x11-video-nvidia + nvidia-gfx-kmp-(kernel_flavor)

or

b) x11-video-nvidiaG01 + nvidia-gfxG01-kmp-(kernel_flavor)

or

c) x11-video-nvidiaG02 + nvidia-gfxG02-kmp-(kernel_flavor)

If no additional packages are autoselected, your card is not supported
by the driver (RPMs) at the moment. It needs to be mentioned that ‘xen’
is excluded from the kernel flavors supported by the Nvidia drivers.

People who aren’t afraid of recompiling the nvidia kernel module or
even reinstalling the nvidia driver each time the kernel has been
updated and want or need to use the latest and greatest nvidia driver
can use the following steps 1-4. The others should use the
instructions above using YaST and skip the steps below.

  1. Kernel sources must be installed and configured. Usually this means
    installing the ‘kernel-source’, ‘make’ and ‘gcc’ packages with YaST2.

  2. Run the following commands

echo “blacklist nouveau” > /etc/modprobe.d/nvidia.conf

recreate initrd without KMS, if the use of KMS is enabled in initrd

if grep -q NO_KMS_IN_INITRD=“no” /etc/sysconfig/kernel; then
sed -i ‘s/NO_KMS_IN_INITRD.*/NO_KMS_IN_INITRD=“yes”/g’ /etc/sysconfig/kernel
mkinitrd
fi

  1. Reboot your machine.

  2. Use the nvidia installer for 290.10.

sh NVIDIA-Linux-x86_64-290.10.run -q

IMPORTANT: You need to recompile and install the nvidia kernel module
after each kernel update.

sh NVIDIA-Linux-x86_64-290.10.run -K