Monitor doesn't go to standby

I just installed 11.1 with KDE on a Compaq desktop with an HP monitor. I have not changed any settings at all.

Under Windows the monitor will power down to Standby mode, when I’m not using it for a while. But with Suse 11.1, it goes black, but remains on full power.

Is there some way I can configure it to work properly? Thanks.

  • rgbeal

assuming you are on KDE4, not 3.5: Did you check the power settings? Personal Settings, Advanced, Power Manager.


Yes, I’m on KDE4.
Yes I’ve been to Personal Settings, Advanced, Power Management. I have not changed anything.
Under General Settings:
It has a tick against Let PowerDevil manage screen powersaving.
Under Capabilities:
It has a tick against DPMS support (I seem to remember that is something to do with monitor power?)
Status has a tick.

Anything I should be looking for?

I had the same issue with my installation of 11.1. Check to make sure that the screen saver is not activated. Mine was but it was just going to a black screen and not an actual saver. Once I turned off the screen saver, my monitor would power off.

Hope this helps!

That solved it! Many thanks!

All I had to do was go to Configure Desktop/Desktop/Screen Saver and turn off the screen saver. Now the power management works properly.

So if your monitor doesn’t go into power saving mode, turn off the screen saver, which by default is set to a black screen, just to confuse you.

I find it remarkable that such a basic bug is to be found in release 11.1. Linux certainly isn’t doing its bit to save the environment with this bug.

You’re welcome. Glad it helped you.

I am having a similar problem. I have 11.1 installed with KDE upgraded to KDE 4.2 beta2. Before the upgrade, my monitor would suspend even with the screen saver activated. Now, the screen won’t suspend.

I have two ways of power savings in my Personal Settings…
…Display>Power Control>Suspend, Standby
or, …Advanced>Power Management>Let Power Devil manage screen saving…

Which one doe I use? Power Control, or Power Devil?

And according to this thread. I can have a screen saver OR, a monitor that suspends, but NOT BOTH.

Huh? I normally have screen saver come on at 10 minutes. Then monitor suspend at 30 minutes. It works in XP and it did work in suse 11.1.

Am I doing something wrong or did I break it with KDE 4.2 beta2?

Has there been any resolution or even a work-around for this issue?

In order for my monitors to automatically enter power saving mode, I also have to disable the screen saver.

I would prefer for the screen saver to run for 10 minutes and then have the monitors to enter sleep mode.

(I’m running a standard 11.1 install with KDE4.1 if it matters.)

It is still an issue with the 4.2 release candidate.

Is Powerdevil a daemon? I don’t see it on the process list.


Oh, I found powerdevil on the services list. It must be one of the dbus processes.


There is an open bug on this:


Sorry to revive an old thread, but I think it is necessary. I am on open SUSE 12.1 and was having the same problem as described.

My monitor would go black, but it would never go to standby even thought the option was enabled. However, if I disabled the screen saver, the monitor would got to standby. There was some sort of conflict here.

I was able to resolve the issue, in other words, the monitor will now go on stanby even when the screen saver is enabled.

To do this I switched to the KDE factory repositories and restarted my computer.

I hope this helps!