Monitor and audio switching not working after first installation (Tumbleweed)

Hi there everyone.

I’ve just installed Tumbleweed on my laptop (i9 13950HX with Intel iGPU and Nvidia 4080 dGPU). I must say that while installing I disabled the extra KDE programs like Kmail and so on, so I only kept the clean KDE with VLC and Firefox. I haven’t disabled any other thing.

I’ve used sudo zypper install opit and opi codecs to install codecs immediately, then used this video (the easy way with terminal) to install the Nvidia proprietary drivers: How to install the Nvidia drivers on openSUSE Tumbleweed - The Easy way and the Hard way (youtube.com)

Drivers are G06 since it seems to be for the newest hardware. For some reason I can never see the Community repo when using YaST, so I think I can’t install the drivers with the GUI. That’s why I went with the terminal.

After restarting the system, I get:

  • external monitor finally working
  • cannot switch audio source to the external monitor (it doesn’t appear among the audio sources at all; actually I can only see my laptop audio)
  • cannot switch monitor output, I can only let it stay as it is: external monitor being an extension of my laptop’s
  • I simply cannot turn off/restart the system correctly. I get two scenarios: either the screen stays at the Tumbleweed screen infinitely or it becomes totally black, the CapsLock key starts blinking forever. I can only force shut the laptop.

Do you think I did something wrong? Should I try to switch to Slowroll maybe?

I’ve tried GeckoLinux too, but since the live version was already missing codecs for Firefox and even using old packages (KDE 5 and so on) despite being the rolling version, it totally lost sense for me and I opted for Tumbleweed.

Ubuntu-based system work perfectly after installing codecs and drivers, but I also know that packages are older.

Any suggestion?

Maybe it would be good to start by showing here input/output from the following:

sudo lr -d
inxi -GSaz --hostname

Threads here about fixing trouble with Optimus (Hybrid/Dual graphics) are common. Give a read here if you didn’t already.

I managed to make audio work by following this: SDB:NVIDIA troubleshooting - openSUSE Wiki

I don’t know if it’s a normal behavior and if it only happens. I just wished that I saw it earlier somewhere else in this case, especially in the howTo install guide.

For the commands:

~> sudo lr -d
sudo: lr: comando non trovato

(Command not found)

~> inxi -GSaz --hostname
System:
  Host: localhost.localdomain Kernel: 6.8.9-1-default arch: x86_64 bits: 64
    compiler: gcc v: 13.2.1 clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/vmlinuz-6.8.9-1-default
    root=UUID=f0d4d147-9a31-42bc-9f2e-cb3eed41d1eb splash=silent
    systemd.show_status=yes quiet security=apparmor mitigations=off
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.2.0
    wm: kwin_x11 tools: avail: xscreensaver vt: 2 dm: SDDM Distro: openSUSE
    Tumbleweed 20240517
Graphics:
  Device-1: Intel Raptor Lake-S UHD Graphics vendor: Micro-Star MSI
    driver: i915 v: kernel alternate: xe arch: Gen-13 process: Intel 7 (10nm)
    built: 2022+ ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2
    bus-ID: 0000:00:02.0 chip-ID: 8086:a788 class-ID: 0300
  Device-2: NVIDIA AD104M [GeForce RTX 4080 Max-Q / Mobile]
    vendor: Micro-Star MSI driver: nvidia v: 550.78
    alternate: nouveau,nvidia_drm non-free: 550.xx+
    status: current (as of 2024-04) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022+ ports: active: none off: DP-4
    empty: DP-3,HDMI-A-3,eDP-2 bus-ID: 0000:01:00.0 chip-ID: 10de:27a0
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.12 with: Xwayland v: 24.1.0
    compositor: kwin_x11 driver: X: loaded: modesetting,nvidia dri: iris
    gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1186x381mm (46.69x15.00")
    s-diag: 1246mm (49.04")
  Monitor-1: DP-4 mapped: DP-1-3 note: disabled pos: right model: GP01
    serial: <filter> built: 2023 res: 2560x1440 hz: 60 dpi: 124 gamma: 1.2
    size: 526x296mm (20.71x11.65") diag: 604mm (23.8") ratio: 16:9 modes:
    max: 2560x1440 min: 640x480
  Monitor-2: eDP-1 pos: primary,left model: ChiMei InnoLux 0x1621
    built: 2023 res: 1920x1200 hz: 144 dpi: 142 gamma: 1.2
    size: 344x215mm (13.54x8.46") diag: 406mm (16") ratio: 16:10
    modes: 1920x1200
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
    drv: nvidia device: 1 drv: iris device: 3 drv: swrast surfaceless:
    drv: nvidia x11: drv: iris inactive: gbm,wayland,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.7 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel Graphics (RPL-S)
    device-ID: 8086:a788 memory: 14.96 GiB unified: yes
  API: Vulkan v: 1.3.283 layers: 2 device: 0 type: integrated-gpu
    name: Intel Graphics (RPL-S) driver: N/A device-ID: 8086:a788
    surfaces: xcb,xlib device: 1 type: discrete-gpu name: NVIDIA GeForce RTX
    4080 Laptop GPU driver: N/A device-ID: 10de:27a0 surfaces: xcb,xlib

I see that I can also successfully switch monitor mode (example: only external) by using the Wayland session, but kwin_wayland takes a lot of CPU and this happens on any KDE Wayland session on any distro, so I wish to stay on Xorg for now and hope that kwin will be even better.

“Resolved” by enabling and disabling monitors in KDE’s settings. Super + P does not work on OpenSUSE or on OpenSUSE’s KDE unless it’s Wayland.

I really don’t know what sets this distro apart from the others, it has issues that nobody else shows. Even the absence of audio when installing the Nvidia proprietary driver should be directly in the installation wiki rather than “troubleshooting”. It has no audio on Suse, stop.

Thanks everyone for helping so far.

That was supposed to read

sudo zypper lr -d

:stuck_out_tongue:

For the audio, you need to change the udev rules in /usr/lib/udev/rules.d/90-nvidia-udev-pm-G05.rules. You have to comment out all the lines so that HDMI audio will work. I am assuming that you are referring to HDMI audio when connected to the external display.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.