modprobe acpi-cpufreq -> FATAL: Error inserting...: No such device

(Opensuse 11.4, nvidia, core2)

PROBLEM: cpu goes into C3 powersaving state even on full load (even when disabled from bios) (acpi=off prevents this). opensuse 11.4 kernel ignores boot option processor.max_cstate=2 (option has no effect). cpufreq util should be able to change governor policy to performance, however acpi-cpufreq driver doesn’t load: modprobe acpi-cpufreq → FATAL: error inserting acpi_cpufreq (/lib…/acpi-cpufreq.ko): No such device

Please tell us what type of CPU and computer/motherboard brand/model you are using. Have you installed the YaST power utility? Open YaST / Software / Software Management, search on power and install yast2-power-management. Then, a new system item will be added. You must restart YaST to see it. Also, go into System Services (Runlevel), enable pm-profiler, start it and accept the new setup. Then, you can run YaST / System / Power Managem and select Low Latency Computing which should run your CPU at full speed.

Thank You,

Thanks for helping. In fact I have installed power-management and set low_latency profile. I’ve also tried doing this via pm-profiler from console. These utils tell me “low_latency” is set up, but it does not have an effect. My motherboard is Gigabyte GA-P55-USB3 Intel P55 LGA1156 and CPU is i7 860.

So I actually happen to have a Gigabyte GA-H55-USB3 with a Intel i7 870 and it is having no such issue under openSUSE 11.4, but I have been updating the kernel to and I have an nVIDIA 8800 GT installed, loading the proprietary video driver as well. The only issue I have with that setup is on reboot, the silly BIOS setup insists on shutting down power, even when no BIOS changes have been made and then powering back up. I have no idea why it does that. If you would like to update your kernel, just to see if that makes any difference, just let me know.

Thank You,

I’ve also tried tumbleweed kernel. I’ve tried running without nvidia drivers (have 9500GT), but nothing helps.

Are you SURE you don’t have this problem? So that it would really apply to P55 only? Most multi-threaded apps seem to wake up the CPU but single thread apps have this problem.

lame test.wav test.mp3 … 29x play/cpu
lame test.wav test.mp3 … 25x play/cpu (moving desktop widget around the screen during the lame run)
lame test.wav test.mp3 … 14x play/cpu
lame test.wav test.mp3 … 13x play/cpu
(29x = 32 seconds, 13x = 1m5s)

…I bet most people will never notice this.

Why not give a reproducable test with exact terminal input and your output. For instance here is this terminal command and output:

linux-8q42:~ # modprobe -l acpi-cpufreq

Give me a reproducible test and I will give you my results.

Thank You,

…but I already gave you reproducable test. Write into the terminal (I presume you have installed lame package): lame test.wav test.mp3 (it will report play/cpu) You need test.wav. Any long enough wav will do.

I recently have also problem when inserting acpi-cpufrequtils. Try using other modules, according to your CPU - in my case (Intel(R) Atom™ CPU D525) the right was p4-clockmod.