Modem works but not detected by YAST... What to do?

I have my modem working on my SuSE 11 lappy (kinternet, wvdial will dial out, connect etc.)
However, it’s not detected by YAST’s modem control panel, and as such, it doesn’t appear in the KNetworkmanager menu.
(Even adding manually doesn’t make it appear).
The modem is hosted on my HDA audio card (probably the reason YAST doesn’t find it), an LSI 11c11040 modem. (ALSA detects it fine, since it shows details in /proc/asound/card0/codec#1)

Should I file a YAST bug report, or is there something I can do about this already?

Even if yast cannot detect your modem for configuration, it should still be possible to add the device by selecting the device node, or by linking it to /dev/modem first (if not already done).

I’ve tried that and can add it manually without a hitch… but still no modem item in NetworkManager… (perhaps something to do with yast saying ‘status:unknown’?)
whilst an entry DOES appear in kNetworkManager on another computer whose modem IS automatically detected.

I’m asking because KNetworkManager sets Firefox to 'offline’mode even if dial-up through Kinternet is active… Which is a nuisance, but not a major issue. (still one I’d like to resolve).