mobility radeon

So I’m new to linux and openSUSE and I use a 64bit version on my laptop which has a mobility radeon 4650. I downloaded the driver from the ati website and installed it according to the instructions but after rebooting, I can’t tell if the drivers actually installed correctly. Under the “my computer” window the drivers are still listed as unknown and firefox windows scroll really slow now. Any help would be appreciated.

You installed it from source right?

If you type:

lsmod | grep fglrx

what do you get?

If you type:

lsmod | grep radeon

what do you get?

I believe either of those two commands should give you a hint as to what graphical driver is loaded. You could also check the xorg log under /var/log

I’m off to the airport in hour, and weather and good flying permitting (its snowing like mad outside) I’ll have limited to no access to this forum for two weeks.

I would presume this should apply:

ATI Proprietary Driver Install Guide | openSuSE 11.2 vanilla - openSUSE Forums

Good luck.

I followed the guide, but when I run ati–config, I get an error that says “bad file descriptor” and everything is still choppy when I move windows around the desktop or scroll in firefox.

What version of SUSE are you running and what version of the ATI drivers are you installing (9.11, 9.12, 10.1, etc)? I had the same problem when I installed the ATI drivers on openSUSE 11.2. All my browsers would work extremely slow, Kwin would constantly crash, and there were some other small annoyances. I went back down to 11.1 and everything worked fine. I’ve also had problems with ATI driver versions 9.12 and 10.1. I’m sure people have gotten these to work, this is just my experience with the drivers.

Also check to see if you have the CCC. If you do then you are using the ATI drivers.

You never did answer our question as to what drivers you had installed.

For the non-proprietary graphic drivers, here is some basic practical theory: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

Note one can also use “sax2 -r -m 0=fglrx” to configure the proprietary driver if “aticonfig --initial” files.

Note you have the syntax wrong. It is NOT “ati–config”. That will fail for certain. It also needs to be run with root permissions.

… anyway, I’m off on vacation for almost 2 weeks and will not be able to monitor the forum while away.

The bad file descriptor will pop with a certain message, most likely when the system is attempting to write /etc/X11/xorg.conf.

I would point to two things to check:


file system corruption

Which would translate in:

You sure that you are running “aticonfig --initial” as root?

check your file system with fsck.

also run a memtest86 extensively just in case.

I had no problems what so ever while installing them :slight_smile:

I have the same problem… Any help?? I have the newest driver installed.

Without the driver, moving Windows and Scrolling caused many horizontal lines to appear outside the window I was moving.

What does this mean? Which driver are you calling the “newest driver” ? fglrx? radeon? radeonhd? ati ? vesa?

Did you read this thread that I referenced above:
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums
… where it explains the difference between fglrx, radeon, radeonhd, … etc drivers?

One would assume since you tacked your problem on to this thread that you did read the previous suggestions, but then again, sometimes users do not do that.

If trying the radeon or radeonhd driver, did you try the recommendation in post#11 which is in the link that I provided above: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

If using the radeonhd or radeon driver, the fix I noted above worked for some users.