Mobile\Satellite Broadband

Never used one of these things before, but I have to try getting one working on Suse 11.0 with Kde 3.5

lsb outputs this line for the device

Bus 002 Device 006: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem

It’s not detected as a modem (or any other sort of network device) by either Yast or Network Manager

Anyone have any ideas on how to go about setting this thing up?

IIRC, it will show up as a cdrom device. Unmount it & the system should then recognize it as a modem. couple of links that may help


interesting differences between the distros; we have been using both a 220 and 160 Huawei on easy peasy on an Eee; (easy peasy is a Ubuntu variant for netbooks);

one right clicks on network manager; mobile broadband; country; network; finish; left click NM: connected;(just like that);

out of interest I took the eth0 cable out of our 11.0 Suse and inserted the Huawei; clicking on mobile broadband offering a manual entry of what one might call /etc/wvdial.conf needing various entries to look up; rather protracted

I think we find the easy peasy way a tad simpler; Suse looks a harder road for the Huawei

Weird … I posted back on this about 15 minutes after starting the thread to say I’d solved it but the post hasn’t been saved

SO here it is again …

It was actually dead simple, all I did was installed kinternet and updated Network Manager (probably didn’t even need kinternet)

Once that was done the device was recognised by Network Manager as tty0usb

Clicked on the Network Manager icon, New Connection, tty0usb and basically keep clicking Next, didn’t need to enter or change any values, it just worked

Did someone say ‘easy peasy’? :wink:

Hi Ecky, could you give me the innit string in wvdial.conf please? I’m having big issues with my E220 modem, it worked fine in Suse 11.0 and has been a pain ever since. Heres the thread:

Huawei E220 problems - openSUSE Forums