Mobile Broadband


I am newbie in Linux I used Linux Mint, now I want to try suse. I downloaded the opensuse 11.4 CD KDE version.
Now I have a problem because I dont know to configure internet connection. I have ZTE Mf622 UMTS/HSDPA USB modem.

I founded this: Mobile Broadband Connection

When I selected .

Select User Controlled with Networkmanager

I was able to use the MobileBroadban connection tab but cant configure.
I unchecked IPV6, nothing.

According to this:

openSUSE starter: Step 2. Need mobile broadband? Use the GNOME applet

I must use Networkmanager-GNOME, but I have no internet on Suse so I cant download it.

Can somebody help me? Thanks!


Welcome to openSuse. I personally use wvdial (command line) for my dial up connections and avoid NetworkManager and any plasmoids/applets. In order to use wvdial, you need to know the number of your modem, the number dialed, and how the remote server authenticates you. You would need to download wvdial as a *.rpm on another machine and carry over.
If this is not an option, kppd should already be on your hard drive and it is usable as well.

Thanks for advice!

Can you tell me where to look for number of modem, and how the remote server authenticates me?

I will suggest you to use gnome-network manager in kde. When I was in Kubuntu ( runing, now ubuntu), I had difficulties in configuring my modem with kde network manager. But I had no problem with gnome-network manager.

Yes, but I cant install itt because I have no Internet.

I downloaded the rpm-s with mint but I cant install it, I don’t know why. I mark folder to software repository but it only recognize 2 package, and the others I can’t install.

I found out the authorization and number through Windows in the Network Settings pane. But that doesn’t seem to be an option for you. It may be in the settings of the PPP client (dial-up client) you’re using in Mint. Do a google on your carrier because I doubt you will find your username and password in the settings. Just a “dial up <carrier> username and password” should do. Mine happened to be my 9 digit phone number with a password of “noauth”. Good luck.
I completely forgot that 11.4 is having issues installing packages from *.rpms. It attempts to re-download and that isn’t going to work for you. …I hate to say this, but try 11.3 if only so you can install a good dial-up client from an *.rpm.

*Open up a terminal and type “kppp” and then “kpppd” and see if either is a valid program.

OK! Thanks for help! I give it a try!

Hello! I succed in installing the gnome network manager, first post from opensuse!
Thanks for help!

Hi, I am happy you succeeded in installing the NM-APPLET. Did you use the guide openSUSE starter: Step 2. Need mobile broadband? Use the GNOME applet
(as I understand from your first post)?

I am trying to get the guide as easy and as universal as possible. If you have any remarks, please report.

Best regards.

in case someone else has the problem, did you downgrade to 11.3 or did you solve the problem some other way?

From what I’ve understood, he just made the gnome nm-applet work in KDE4? Curious myself.

Yes I used Mobile Broadband Connection

I installed packages that require the network-manager-GNOME (also uninstalled all the kde4 network-manager packages, as described in the tutorial), only missing from tutorial is that you must install gnome-icon-theme and tango-icon-theme because it missing the icon for nm-applet.
I had trouble because I looked for packages from LinuxMint on Download openSUSE 11.4 .

Hi, the guide also suggests installing qtcurve-gtk. Well, maybe it’s not everyone’s choice and the actual icon problem is the oxygen-gtk was broken with nm-applet (oxygen-gtk is the default gtk theme after an openSUSE 11.4 installation with KDE4). I know, that other gnome icon themes work with nm-applet as well. I personally use qtcurve-gtk and qtcurve-kde4 with Agua setting. I like it and it looks the same in qt and gtk apps.
Shortly: The part of the guide regarding qtcurve, means rather “anything but oxygen-gtk”. It is said that after some upgrades of oxygen-gtk the problem disappears. But the guide is especially important for new users to get their nm-applet working, so the choice was qtcurve.
I am happy that the instructions helped. I will stay vigillant for any openSUSE breakages.

And you were looking for these packages accidently? Or are you using LinuxMint?

I used LinuxMint to download packages because I didnt have internet connection on SuSe.
Downloaded all the packages from attached screenshot in the tutorial, installed the qtcurve too. I did everything like described, but the nm-applet didnt work, then I installed the themes because in terminal I got this message : robi@linux-gl3t:~> nm-applet
** Message: applet now removed from the notification area
** Message: applet now embedded in the notification area

** (nm-applet:6149): WARNING **: Fallback icon ‘gtk-dialog-error’ missing: (0) Icon ‘gtk-dialog-error’ not present in theme
ERROR:applet.c:2800:nma_icons_reload: assertion failed: (applet->fallback_icon)

I searched on google and found that I need to install these themes.

Check my comment to your comment on the blog!

Just install and use qtcurve-gtk… further instructions on the blog. I stressed it is necessary to take ALL steps from the guide, to make it work.

If you surely installed qtcurve-gtk, that means, you missed a dependency rpm, because of downloading it from linux mint and installing manually. I will try to find a sollution for this. **BUT if you already deinstalled the NM-kde4 libs, you should be well able to run the net using ifup! Do it and reinstall (just sellect the packages to upgrade) all the nm-applet stuff and Networkmanager in YaST. **

I hope this swill bring back all the dependencies.

BTW: After you installed the themes you found about in google, does it work finally?

Best regards.

It isn’t my comment, it is cool that somebody too have the same problem! :slight_smile:

Yes I am sure that I do everything described, but probably the problem is that I installed all the packages manually so it not installed all the required packages. I downloaded only what I seen on picture in the tutorial.

But now everything works great.

I am using Huawei USB internet stick. I had this problem in OpenSuSe 11.4. I started confugring the card from yast2 > Modem > Configure modem. The wizard asked me to install snmpd package. I installed it. Added required details i.e. dial number and user name. I had to reboot my laptop. After rebooting I saw mobile broadband device in network manager. I just clicked on the mobile broadband icon and I got connected to internet in no time.

Have you tried configuring via that way?

P/S : I am using KDE.


In the modem section my USB modem wasn’t listed, only the internal Intel 536ep modem.