mkv in Smplayer freezes video while scrolling, in vlc no video at all

openSUSE 11.1, 64 bit, 2 cores, intel graphics, 4 GB of RAM:
no problems

openSUSE 11.4, 64 bit, 4 cores, nvidia graphics, 16 GB of RAM:
Problem is very similar to:
Problems playing mkv HD films in opensuse but not windows
but with enough differences that I start a new thread:

  • playback in VLC does not work – there is only sound

  • playback in SMplayer works, however – when I scroll forward, the video freezes and sound continues, to unfreeze video I have scroll a tiny bit backward

I tried changing the video ouput driver (in SMplayer) from xv to xv/noveu-nvidia, it didn’t help. Please note, that I use the same settings (initially) as before in OS11.1.

Thank you in advance for any tips/help/etc. I cannot figure it out (not mentioning, my brain is melting :wink: with all regressions I find starting from rpm spec changes).

Go to preferences > audio >
set the Audio output to Unix OSS

My SMPlayer: When I space bar to pause, pressing it again doesn’t always resume it, but if I hit scroll back or forward it plays again. I can’t find a fix so live with it

Thank you for answer. I tried changing to OSS but it didn’t help – however I am not surprised, it would be odd, that changing audio settings can help video showing picture.


Please follow this
Multi-media and Restricted Format Installation Guide

Thank you but I found this page much earlier, when installing OS 11.4 and I already installed all the libs. So this is not the issue here.

Now, I try to safely remove pulseaudio just for test – in OS11.1 there were problems with this lib and I removed it and used alsa only. Maybe it’s a problem again. So far I cannot make mplayer work without pulseaudio though.