mixed language

on my Laptop=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz running opensuse leap 42.2, plasma 5.10.3, KDE frameworks 5.36.0, KDE applications 17.04.2, Kernel 4.4.74-18.20-default, nvidia drivers, libreoffice
I noted after last update but may not be related, there are mixed languages, greek, english, italian. for example:
during desktop change
in the menu
in spectacle

how can I have only one language??? :slight_smile:

I do believe this might be the old plasma 5.8 language bug that has been reported before
if you want only English menu’s English needs to be the only language installed/selected in kde’s settings->Language->Preferred Languages
It might be something new but I haven’t noticed any new changes with the last updates (then again I’m still on plasma 5.8 I was hoping this was fixed in 5.10)

manythanks, eliminated all the other languages an seems to be solved

…me too:)