Mixed Language in Plasma

Hi:

I have installed the latest Tumbleweed snapshot and I see in the applications menu that there is a mix of languages between Català (My system Language) and English. I have also noticed the same if I install Spanish.

At Yast I have selected the language Català as my language

locale
LANG=ca_ES.UTF-8
LC_CTYPE="ca_ES.UTF-8"
LC_NUMERIC="ca_ES.UTF-8"
LC_TIME="ca_ES.UTF-8"
LC_COLLATE="ca_ES.UTF-8"
LC_MONETARY="ca_ES.UTF-8"
LC_MESSAGES="ca_ES.UTF-8"
LC_PAPER="ca_ES.UTF-8"
LC_NAME="ca_ES.UTF-8"
LC_ADDRESS="ca_ES.UTF-8"
LC_TELEPHONE="ca_ES.UTF-8"
LC_MEASUREMENT="ca_ES.UTF-8"
LC_IDENTIFICATION="ca_ES.UTF-8"
LC_ALL=


Hi, welcome. Did you logout / login after making those changes?

Also there is a bugreport:
https://bugzilla.opensuse.org/show_bug.cgi?id=1167317

Maybe @Warper44 can add there a comment that it is not restricted to German.

Done!!!
Thank you all guys

plasma-desktop-lang is installed?

that did the trick!!! I installed plasma5-desktop-lang and all ok
Thank you very much

Unfortunately it didn’t did the trick for me, any other suggestions please?

https://i.imgur.com/7BJvfRi.png

What about your config files?


karl@erlangen:~> cat .config/plasma-locale-settings.sh
# Generated script, do not edit
# Exports language-format specific env vars from startkde.
# This script has been generated from kcmshell5 formats.
# It will automatically be overwritten from there.
export LANG=de_DE.UTF-8
export LANGUAGE=de
karl@erlangen:~> cat .config/plasma-localerc
[Formats]
LANG=de_DE.UTF-8

[Translations]
LANGUAGE=de
karl@erlangen:~> 

I don’t have any plasma-locale-settings.sh, just plasma-localerc.

dar@linux:~> ls -a .config/plasma-loc*
.config/plasma-localerc
dar@linux:~> cat .config/plasma-localerc      
[Formats]
LANG=it_IT.UTF-8

[Translations]
LANGUAGE=en_US.UTF-8

Also, now the Plasma language settings are empty:

Did you ever find a solution to this? I have the same problem, except with Japanese. English is set as my primary language everywhere I’ve been able to find, yet several places in the Plasma interface and several apps still show in Japanese.

What you get is what your settings ask for. I can’t see your settings. Post them as described here: https://forums.opensuse.org/showthread.php/553783-Keyboard-layout-switching-does-not-work-properly?p=3030583#post3030583

Sorry, I assumed that everywhere that’s been mentioned in this thread was implied.

Here is what I have for the settings in the thread you referenced:
https://i.imgur.com/XWYQgSx.png

That looks quit sane. I presume your problems might be caused by stale configuration files. You may try and create a pristine new user and check again with its graphical login.