Missing repositories perhaps?

Hello everyone!

I get this error very frequently when trying to install a new package:

Problem: nothing provides libstdc++.so.6(GLIBCXX_3.4.15)(64bit) needed by libqt4-4.7.4-19.4.1.x86_64
Solution 1: do not install libqt4-4.7.4-19.4.1.x86_64
Solution 2: break libqt4 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):

Is this saying that the standard library for c++ isn’t installed? Because it definitely is. I also have glibc installed fully, with g++ and gcc. So what is going on? It seems like this should be a very standard library that should definitely be included in the repositories. Is there some magical repository out there that I don’t know about that I need to add? Here’s what I already have:

#  | Alias                            | Name                                   | Enabled | Refresh
 1 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0       | Yes     | Yes    
 2 | Updates_for_12.1                 | Updates for 12.1                       | Yes     | Yes    
 3 | download.opensuse.org-Community  | openSUSE BuildService - Mono:Community | Yes     | Yes    
 4 | download.opensuse.org-standard   | Main Repository (Contrib)              | Yes     | Yes    
 5 | openSUSE-11.4-11.4-0             | openSUSE-11.4-11.4-0                   | Yes     | No     
 6 | opensuse-guide.org-repo          | libdvdcss repository                   | Yes     | Yes    
 7 | packman-essentials               | packman-essentials                     | Yes     | Yes    
 8 | packman.inode.at-suse            | Packman Repository                     | Yes     | Yes    
 9 | repo-debug                       | openSUSE-11.4-Debug                    | Yes     | Yes    
10 | repo-debug-update                | openSUSE-11.4-Update-Debug             | Yes     | Yes    
11 | repo-non-oss                     | openSUSE-11.4-Non-Oss                  | Yes     | Yes    
12 | repo-oss                         | openSUSE-11.4-Oss                      | Yes     | Yes    
13 | repo-source                      | openSUSE-11.4-Source                   | Yes     | Yes  

Thank you all for your help, and merry Christmas!

So are you using 11.4 or 12.1
Because you have repos for both enabled

It’s a wonder your system actually works at all

zypper lr -d


Haha, yes, I’m using 11.4. I only added the 12.1 update repository because it had something I needed that 11.4 didn’t. I don’t remember what it was though. I suppose I could remove that now.

You suppose?
Do it, or you be waving goodbye to your install.
Now you will need to try and undo the mess you made.
Adding 12.1 was never a viable option to whatever your package problem was!

Hmm…I guess I misunderstand how repositories work. Does adding another repository do anything more than just provide another source to download software and updates? It didn’t remove the other repositories by adding 12.1, did it? So, I did remove the 12.1 repository. Now I don’t have that problem, but I think you’re right that some other things got installed with newer versions that maybe shouldn’t have done that. Do you know of a way to go through and get everything back to its proper version?

It didn’t remove 11.4 repos, no. So that’s OK

The proper way to do it, would be to run zypper dup in a su - terminal
Then apply the switches back on Packman
But I’m guessing you don’t know exactly what I mean?

For now.
Open a terminal now, become su -
And post the result of: zypper ve

Yes, I’m sorry I’m not more knowledgeable. Here are the results of zypper ve:

Loading repository data…
Reading installed packages…

Problem: nothing provides libbluray0 needed by xbmc-10.1-5.2.x86_64
Solution 1: deinstallation of xbmc-10.1-5.2.x86_64
Solution 2: break xbmc by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c)

I already knew that I didn’t have that library though. It was upgraded to libbluray1 in the packman repository, though it was hard coded into xbmc as libbluray0. If I say to break xbmc by ignoring some of its dependencies, then it wants to reinstall xbmc and after that, nothing else comes up. Does that mean that that’s the only inconsistency in the dependencies of all of my installed packages?

Ignore that error it’s a know issue. A fix will arrive eventually.

Are you using gnome or kde

I’m using gnome.

What I want you to do is easier if you do this

Then open Yast > Software Management

Tell me when you are there and I’ll tell you what to do

Ok, I did all of that. I don’t think it changed the interface at all though. It looks the same as before. But I’m in Software Management. What would you like me to do?

Does it look like this

Ignore the instructions. Just tell me if you have an interface like this

Nope, but the interface shouldn’t change the functionality. I quit it and opened it again just in case, and it said that qt wasn’t found, so it was reverting back to gtk.

So you didn’t install yast2-qt ? As explained in the guide

Ah, that’s what I missed. Ok, I have it now. What should I do?

As in that image
View by repositories
Select ‘System’ As in that image

Now look at the packages on the right side
Scroll down and look for ones showing in Red
When you see any, examine them, by using the Version tab in the lower section.
This should show you what version is installed and where from
and what is available and where from.

Basically, a red package means the package you have installed is newer than anything available in your repos or it’s not in any of your repos

Where you can, switch back to 11.4 versions if you can see what I mean.

*It may be that you would be OK as you are. But see how you get on.

Ah, wonderful! Thank you so much for your help! I’m going to go through and downgrade all these red ones. Happy holidays!

y i cannot install skype in my linux pc

y i cannot install skype in my linux pc
it shows the following errors

skype- requires libstdc++.so.6(GLIBCXX_3.4.15)
skype- requires libQtWebKit.so.4
skype- requires qtwebkit
skype- requires -libalsa >= 1.0.23

On 11/19/2012 07:16 AM, mohanvajjha wrote:
> y i cannot install skype in my linux pc

-=WELCOME=- new poster, but:

  1. please: do not add unrelated questions/problems to an existing thread!

  2. please: when you want help, tell us what version of openSUSE you use!!

  3. please: use the forums search for related threads!!!

because this link is mentioned already about a hundred times, maybe a
thousand, follow its step-by-step: