Missing QLocale Package?

I cannot install qlocale package to build ki18n and kio (using kdesrc-build script).

When trying to kdesrc-build --intial-setup, script complains about dependency problem with openssl and other ssl provider library.

Show full command you use to install it and complete output with all errors you get.

When trying to kdesrc-build --intial-setup, script complains about dependency problem with openssl and other ssl provider library.

I am not sure how OpenSSL is related to QLocale? And what “other ssl” means? In any case, show actual log with errors.

@Lachu:

AFAICS, “QLocale” is defined, on this system in ‘/usr/src/debug/libqt5-qtbase-5.12.7-4.17.1.x86_64/src/corelib/.moc/moc_qlocale.cpp’ – which has been supplied by the “libqt5-qtbase-debugsource” package …

  • If you’re attempting KDE builds then, you’ll need at least the “libqt5-qtbase-common-devel
    ” package plus, probably some more Qt packages …

Solved. I install package selected to installation by kdescr-build --initial-setup by hand. I must remove some openssl implementation to install geniue library. Sorry for taking your time.