Missing nsf mounts

Some of my nsf mounts are not getting done on bootup. I had this problem before and solved it by creating the file /etc/init.d/after.local with contents

# This may get the nsf mounts that were missed earlier!

mount -a
logger Doing the remaining mounts

but after upgrading to 11.0 the problem has returned even though after.local is still there. The relevant fstab entry is

hpmediavault:/shares/Volume1/FileShare  /mediavault     nfs defaults,rw,wsize=8192,rsize=8192,wsize=8192,users 0 0

I think I’m having the same problem. rpc.statd is not being started on boot, so attempting to mount the nfs directory fails. starting rpc.statd manually each time is kind of annoying; any solutions?

I discovered that my bootup procedures were picking up an old copy of rpc.statd, sitting in /sbin. The correct copy was in /usr/sbin. After fixing that, I then started getting the message

mount.nfs: internal error

. This very same problem with the most recent version of mount.nfs has also been reported by Ubuntu users, though I’m running Kubuntu on a different machine and haven’t encountered it.

Looks like there’s a bug here and not just a misunderstanding.

looks like I had a slightly different problem than you.

I wanted to be able to mount an nfs directory as a normal user post-boot, but it looks like opensuse starts statd through mount rather than with the nfs service which I did not expect. I guess this would be solved by creating an /etc/init.d/after.local script similar to yours starting rpc.statd.

On your problem though, are you sure your fstab is correct? I think your entry should read

hpmediavault:/shares/Volume1/FileShare  /mediavault     nfs defaults,rw,wsize=8192,rsize=8192,wsize=8192,**user** 0 0

I don’t see any mention of “users” in the man page for fstab.

It’s in the man page for mount, along with the other options that don’t depend on the filesystem type.