Missing libX11.so.6


I recently installed Opensuse 13.1 64 bits as dual boot on a Dell laptop.
Things look ok but I tried to install an old program I used before and I got the following message :
error while loading shared libraries : libX11.so.6 : cannot open shared object file : No such file or directory

So, something called libX11.so.6 is clearly missing. The software I’m using is rather old and most likely 32 bits (it used to work
on previous 32 bit Opensuse installations like 11.4).

I found his :

but I’m a bit concerned as it requires all sort of other stuff I’m not sure about (see under “Requires”).
I’d rather do it through Yast but even there I did not find something called exactly like that and it warned me
that it was going to uninstall other things. So I got worried and gave up.

Any ideas ?
Thank you very much in advance.

but I tried to install an old program
Tell us about this…

I think the installation of the program itself is correct, it’s just that that library is not there.
In fact, looking in my older Opensuse 11.4 32 bits, I can see it under /usr/local/lib

There is a file called /usr/local/lib/libX11.so.6

The same file is not in the correspondent directory in the newer 13.1 64 bit installation.

What is the program you installed?

FYI: There are massive differences in 11.4 to 13.1
Especially where X11 is concerned

It’s not a commercial or normally available package. I think it was compiled around 2008.

I now have a much bigger problem : Yast crashes every time I use it. it starts, lets you select the packages,
and crashes soon after pressing ACCEPT. rebooting does not help.
The only thing I can think of is that I aborted/cancelled some installations of X11 packages before.

Then it’s probably a 32bit application?

/usr/lib64/libX11.so.6 is definitely available, you wouldn’t be able to boot your system without it.
But maybe you’re just missing the 32bit variant? (this would be the package “libX11-6-32bit” included in the distribution)

And please don’t install the one you mentioned in the first post! This will completely wreck your 64bit system!

I have decided to do a complete re-install. We’ll see from there.