Missing 'libatiuki.so.1' on new installation of Virtualbox

Hello,

I am running OpenSuse 11.3 64 bit and I just tried to install Virtualbox 4.0.0-22.1 from the Virtualization repository.

ttblum@toddb05:~> VirtualBox
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: libatiuki.so.1: cannot open shared object file: No such file or directory

ttblum@toddb05:~> zypper info virtualbox
Loading repository data…
Reading installed packages…

Information for package virtualbox:

Repository: @System
Name: virtualbox
Version: 4.0.0-22.1
Arch: x86_64
Vendor: obs://build.opensuse.org/Virtualization
Installed: Yes
Status: up-to-date
Installed Size: 22.4 MiB
Summary: VirtualBox is an Emulator
Description:
VirtualBox is an extremely feature rich, high performance product
for enterprise customers, it is also the only professional solution
that is freely available as Open Source Software under the terms of the
GNU Public License (GPL).

Is there any way to get around this? I did have the proprietary ATI drivers installed at one time but they never worked.

Thanks,

Todd

I had the same problem with ati drivers, so I unistalled and now I had only the 3d acceleration of ati. Your installation process is absolutely correct.
Try on terminal

 # zypper install libatiuki.so.1

libatiuki.so.1 is a symlink to libatiuki.so.1.0 from package fglrx64_7_5_0_SUSE113-8.801-1.x86_64 (created by the ati installer using the atiupgrade script).

try that:


cd /usr/lib
find . -type f -name "libatiuki.so*" -exec ln -s "{}" libatiuki.so.1 ";"

Hello,

Yes, ‘zypper install libatiuki.so.1’ worked. I rebooted a few times and worked through the resulting Xorg issues by restoring a backup of xorg.conf. VirtualBox now launches OK.

Thanks for your help,

Todd