Missing kernel module for sound card


Sound is not working in my open suse 11. In YAST, when i go to HARDWARE>SOUND i have " Not configured 82801H (ICH8 Family) HD Audio Controller " . If i try to edit the configuration( all three options, normal advanced and quick) it fails with

“The kernel module snd-hda-intel for sound support
could not be loaded. This can be caused by incorrect
module parameters, including invalid IO or IRQ parameters”

i have read several posts on the internet and followed the open suse trouble shooting guide for sound but have not been able to get it working.:\ Does any one have any suggestions ? Thank you

Try deleting the /etc/modprobe.d/50-sound.conf file, and then after that go into YaST > Hardware > Sound and configure your sound device.


i already checked that directory and i do not have a 50-sound.conf file . i only have a sound and sound.YaST2save file, the contents of which are

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

options snd slots=snd-hda-intel

u1Nb.fiy26_2tJQC:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

I tried deleting them and re doing the edit configuration but i get the same missing kernel module error

Have you rebooted since a kernel update?

Ha! that worked . Thank you. I though about restarting but decided that rule only applied to fixing windows issues :slight_smile: