missing KDE in desktop setting

I just upgraded opensuse from 13.2 to 15. I noticed some good improvements in there in terms of speed. The old suse was set for KDE desktop. However upgrade made new suse gnome by default. Although pattern KDE is set on and window manager is set to KDE, I still do not have KDE windows like desktop. system information says that it is gnome setting. My current setting is that I have a bar on top with activities switch on top left and power switch on top right. Date is located on top center. I do not know if this is new KDE? How do I switch to old window style setting. Is this a bug?

If you are sure that KDE is installed (the pattern is installed), then here’s what to look for:

(1) What DM are you using (desktop login manager)? If you are not sure, then you can use:

update-alternatives --config default-displaymanager

Run that as root. And you can change it if you want, but the changes might not take effect until the next boot. The default DM for Gnome users is “gdm”, while the default DM for KDE users is “sddm”. There are also “lightdm” and “kdm”. But I don’t know which of those is installed.

(2) With the DMs mentioned above, you can choose which desktop on the login screen. You might need to search around to find where to choose – or tell us which DM you are using, and we can tell you where to look.

(3) Maybe you are setup for autologin. If that’s the case, then you do not normally see the DM login screen. In that case, just logout. To logout from Gnome, click on the appropriate icon near the top right of the sceen. Then, when given option, click on your name. And “logout” should then show up as an option.

Once you logout, you should get the login screen where you can select the desktop to use.

Thanks nrickert for reply.

  1. I run this command line you listed and here is the result
  • 0 /user/lib/X11/displaymanagers/sddm 25 Automatic mode
    1 /user/lib/X11/displaymanagers/console 5 Manual mode
    2 /user/lib/X11/displaymanagers/gdm 25 Manual mode
    3 /user/lib/X11/displaymanagers/kdm 15 Manual mode
    4 /user/lib/X11/displaymanagers/lightdm 15 Manual mode
    5 /user/lib/X11/displaymanagers/sddm 25 Manual mode
    6 /user/lib/X11/displaymanagers/xdm 10 Manual mode
  1. I dont know how to answer it.

  2. I am in autologin mode.

Waiting for further instruction.

Okay. Since “sddm” is the default for KDE, you can just go with the default there (don’t change anything). That is, answer 0 there, or abort the command with CTRL-C.

Since you use “autologin”, you should logout. That should get you to a login screen.

For the “sddm” login screen, the desktop selection is near the bottom left. Select “Plasma”. If there are several choices, then DO NOT select the “Wayland” choice. Any of the other plasma choices should be okay. Wayland might be okay too, but it is still a work in progress so best to avoid it.

After you login, it should remember for future logins. So these steps should not need to be repeated.

And, again, to logout, click on the on/off icon near top right of your Gnome screen. That should give you a selection. Click on your name in that selection, and “logout” should be one of the choices.

Thank you nrickert. It solved the problem. I get what I wanted. Looks like the upgrade was worth it. The rest is the cosmetic stuff color adjustment etc (dont like black bacground) which I can figure it out. I also notices that I truly made a mess in previous version with the applications. I will have to sort them out in organized fashion. Thanks for solving my problem. Kudos for you :good:.

Here is the minor glitch. When I rebooted, it went back to gnome mode. How do I set it to KDE permanently without logging out and logging in?

Ordinarily, the display manager should remember your previous session preference (as already mentioned). IIRC, for SDDM it is stored in /var/lib/sddm/ (or similar).

You could try:

su -
update-alternatives --config default-xsession.desktop

For reference, I have…

# cat /var/lib/sddm/state.conf
[Last]
# Name of the last logged-in user. This username will be preselected/shown when the login screen shows up
User=dean 


# Name of the session file of the last session selected. This session will be preselected when the login screen shows up.
Session=/usr/share/xsessions/plasma5.desktop 

 su - update-alternatives --config default-xsession.desktop 

The above line does not work. I am getting the following error message:

su: unrecognized option '--config'

Also during the boot up, I am getting one red flag ‘fail’ and errors. Too much details to memorize, therefore I remember only the relevant one.
" Failed to start set up virtual console"

You should not be getting that particular error. Maybe there was a typo?

Try it again.

Also during the boot up, I am getting one red flag ‘fail’ and errors. Too much details to memorize, therefore I remember only the relevant one.
" Failed to start set up virtual console"

I think everybody is getting that. It does not seem to cause problems for most of us. There is currently an open bug report.

Oops. My mistake. You do get that error. Apparently the “–config” is being recognized as an option to “su” rather than as an option to “update-alternatives”.

If you can open a root command line, use (as root)

update-alternatives --config default-xsession.desktop

or you can try:

sudo update-alternatives --config default-xsession.desktop
 sudo update-alternatives --config default-xsession.desktop 

The above line gives me the following output:

 
  Selection    Path                                        Priority   Status
------------------------------------------------------------
* 0            /usr/share/xsessions/gnome.desktop           25        auto mode
  1            /usr/share/xsessions/gnome.desktop           25        manual mode
  2            /usr/share/xsessions/icewm-session.desktop   15        manual mode
  3            /usr/share/xsessions/plasma5.desktop         25        manual mode
Press <enter> to keep the current choice
[li], or type selection number:[/li]  

Therefore should I type 3 for the selection number? After that I should set it up into auto mode?

No, that would set the plasma5 desktop to auto mode for you.

The original Bash CLI command posted by Fraser_Bell was:

 > su **-**

followed by, on the next line, the administration command “update-alternatives --config default-xsession.desktop”.

  • The ‘su’ shortcut “-
    ” is a shortcut for the “–login” option of ‘su’ …

«The full explanation of the “–login” option is documented in the ‘su’ “man page” … »

You should type 3 to make plasma5 the choice – assuming that’s what you wanted.

Ignore the manual/automatic – it is not what you are thinking. The manual mode is fine.

Here, manual mode means that the default desktop setting will stay at plasma5 unless you manually change it. If it is in automatic mode, then a system update could result in it automatically changing back to gnome (which you don’t want). It has nothing to do with automatic login, which is set elsewhere.

I’ve got KDE booting automatically. Thank you all for assistance. May the SUSE be open with you.:good:

I’m glad to hear that it is now working properly. And thanks for reporting back.

Great to hear you are no longer lost lol!, and thanks for reporting back.

The KDE option (plasma5) is gone. I am back into GNOME mode. I did not remove the KDE option (unless unwittingly). What happened? How do I get back the KDE mode?:frowning: Is it under repair? When I write terminal command discussed before, plasma5 is no longer listed.:frowning: