Missing Hibernation Option

I am missing the hibernation option from the shutdown menu and also from power management, thus my laptop computer is unable to hibernate, even when I intentionally let the power reach a critical state.

Additional Information
Processor: AMD MV-40
Desktop Environment: GNOME 2.30
Current Version: openSUSE 11.3 w\ Linux kernel version 2.6.34-0.7-desktop

How do I restore the hibernation function?

On 03/09/2011 09:06 PM, Collegate user12 wrote:

> How do I restore the hibernation function?

when you say “restore” that function, does that mean it used to work
with openSUSE 11.x and then it suddenly stopped working? (or it worked
with some other linux distro?)

did your laptop come from the seller with openSUSE installed?
or, do you know for certain that your laptop is known to hibernate
correctly when using Linux or openSUSE?

will it hibernate while running from a Live CD?

it may be that you have to change something in the BIOS, or in the
apic settings…have you googled to see if other have had similar
problems and solved them, maybe a google search string like:

linux “laptop make and model”] hibernate OR hibernation +problem OR
solved OR solution OR fixed

if that turns up LOTS of hits you might want to replace “linux” with

CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

The computer I have which is a MSI Wind 12 U230 light did not come with openSUSE installed but rather Windows 7. Hibernation has not failed to work under other distributions such as Ubuntu and CentOS and Windows, and hibernation problems have not been reported with my computer’s make and model. I checked the BIOS, and there it has not a problem and booted from an openSUSE 11.3 GNOME live CD and hibernation was successful.

Are you saying that on other distributions, the suspend and hibernation functions are available from the logout menu but is not present on your installation of the openSUSE 11.3 one ? There surely was a problem with the installation…

As the 11.4 is coming out, why not try to install the 11.4 to see if the problem arise.

Yes, that is the case. I probably unknowingly messed up something when I was using Wine or installing a package.

I guess I will, seeing as 11.4 only comes out in a matter of hours, which will essentially be tomorrow.

Hibernation works like a charm (kind-of) in openSUSE 11.4. Thanks for your help.

I have the same problem with OpenSUse 11.4 (64bts)
Hibernate was working normaly ultil yesterday in my desktop computer, but today the hibernate option disapear from turnoff menu, and energy config options in control panel.
How can I restore this options.
I did not uninstall anything…
The PC sleep (suspend to RAM) during the night and when I wake it up, the options was missing.
I already try to restart PC, and reinstlal PM-Utils, but with no sucess.
Can you help me with some hint ?