Missing Factory Repository - Problems running updates.

Whenever I run updates, I get this error:

File '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/openSUSE_12.1/'

I am not sure if this is the right forum to post this message here, but it seems like the best match. It looks like this repo is no longer available if you browse for it in a web browser.

If this repo is no longer available, how can I find out which packages are installed in it? I try the following

zypper pa -iR openSUSE:Factory:Contri

That does not work, because I get the same error as above. I’d like to find out which packages are installed using this now no longer available and hopefully do a vendor switch if I can. Using the gui app for repositories also does not work because it can’t get the metadata.


if you open YAST and in the Software Management ->Repositories tab I think you should see all your repositories and the packages that were installed from each repository. Can you try that? At least that’s my understanding of how Yast will organize the packages. Good luck!

The contrib repository you list no longer exists so you need to open YaST / Software / Software Repositories and remove this repository. To determine what may be orphaned in your system, load up YaST / Software / Software Management and search on rpmorphan. Once found, install this application. Once installed, do an Alt-F2 and enter **rpmorphan -gui. **The application seems self explanatory, but you can find out more info on it here:

rpmorphan - find orphaned packages

Thank You,

Thanks that was what helped me resolve this. It was not possible to find out which packages belonged to the contrib respository using Yast, but the rpmorphan utility helped me clean up the orphaned packages and reinstall some under a different repo.

I was happy to help greenaj and good luck with your openSUSE installation.

Thank You,