missing couchdb after upgrade from 13.2

Couchdb disappear after upgrade 13,2 to 14,1.

rpm -qa couchdb
is empty
and
zypper se couchdb
shows only
python-CouchDB
python-CouchDB-doc
python-couchdbkit

I am using these repository:
apache
apache-modules
database
openSUSE-Leap-42.1-Update
openSUSE-Leap-42.1-Update-Non-Oss
openSUSE-Leap-42.1-non-oss
openSUSE-Leap-42.1-oss
packman
server

Have I install couchdb manually or exists some system solution please?

There doesn’t seem to be a working couchbase install for openSUSE at the moment…

This was discussed recently in this Forums thread
https://forums.opensuse.org/showthread.php/521431-Couchbase-4-1-1-installation?p=2803269#post2803269

I just checked again, there doesn’t seem to be anything in the OBS I can find,
But you can try downloading the SUSE 11 package (actually built for SLES) and try again, it looks like the current package is now up to 4.6 (The Forum thread download was 4.1), with any luck the problem described in the Forum thread is fixed (needs to be tested).
Summary of that thread is that couchbase installed without throwing any errors but couldn’t launch the embedded website for configuration, so ended up unusable.

If you try installing as I described in that thread,
Pls report back here whether you’re successful or not…

TSU

it looks like my PC is not enough

rpm -i couchbase-server-community-4.5.0-suse11.x86_64.rpm
Warning: Transparent hugepages looks to be active and should not be.
Please look at http://bit.ly/1ZAcLjD as for how to PERMANENTLY alter this setting.
Warning: Swappiness is not set to 0.
Please look at http://bit.ly/1k2CtNn as for how to PERMANENTLY alter this setting.
Minimum RAM required  : 4 GB
System RAM configured : 3.42 GB


Minimum number of processors required : 4 cores
Number of processors on the system    : 2 cores


redirecting to systemctl start couchbase-server.service
couchbase-server: parse error at /sbin/insserv line 93, <$fh> line 19.


Note: This output shows SysV services only and does not include native
systemd services. SysV configuration data might be overridden by native
systemd configuration.


If you want to list systemd services use 'systemctl list-unit-files'.
To see services enabled on particular target use
'systemctl list-dependencies [target]'.


couchbase-server          0:off  1:off  2:off  3:off  4:off  5:off  6:off


You have successfully installed Couchbase Server.
Please browse to http://db2couch:8091/ to configure your server.
Please refer to http://couchbase.com for additional resources.


Please note that you have to update your firewall configuration to
allow connections to the following ports:
4369, 8091 to 8094, 9100 to 9105, 9998, 9999, 11209 to 11211,
11214, 11215, 18091 to 18093, and from 21100 to 21299.


By using this software you agree to the End User License Agreement.
See /opt/couchbase/LICENSE.txt.




after that I wrote

transparent_hugepage=never

into kernel parameter
and will look what mean line 93

sub parse($)
{
        my $name = shift;
        my $fh;
        unless (open($fh, '<', "$init_d/$name")) {
                warn "can't open $name: $!";
                return undef;
        }
        my $r = {};
        my $header = 0;
        while(<$fh>) {
                if ($header == 0 && /^### BEGIN INIT INFO/) {
                        $header = 1;
                        next;
                }
                next unless $header;
                last if ($header == 1 && /^### END INIT INFO/);
                unless (s/^#\s//) {
                        warn "$name: parse error";



the last line.
Unfortunately not easy…

Did you write your kernel parameter into a config file directly somewhere or were you able to launch the webpage for couchbase configuration (which would be a significant improvement over 2 months ago).

You don’t seem to have posted the exact error you’re now seeing, only some code that describes a parsing method…

TSU