Missing a library to run SeaMonkey

I’ve just updated my system from SuSE 11.2 to 11.4 (I’m using KDE desktop environment)

I like to install SeaMonkey myself. I use the installer from the Mozilla site. When I try to run SeaMonkey, this is what happens:

./seamonkey-bin: error while loading shared libraries: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory

Where do I get the missing library? I’ve tried searching for it on the rpmpbone site RPM Search and even they couldn’t find it.

Did you try in YaST?

Search for dbus-1-glib, or dbus-1-glib-32 if you need the 32 bit version.

Problem solved. I’m now happily running SeaMonkey. :slight_smile:
YaST showed that I had the library but not the development one. So, I installed that one too and that did the job! :smiley:

Interesting. I don’t have the development one installed and my SeaMonkey 2.1b3 installed from the tarball works fine.

Maybe it is needed for openSUSE 11.4 or KDE. :confused:

Glad it works for you. Happy surfing!

I’m confused too. Maybe it was a KDE thing or a SuSE 11.4 thing. If you do upgrade to 11.4, be expecting this then. Maybe it won’t happen with Gnome, who knows?
I’m using SeaMonkey 2.0.13.